Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Mar 2007
    Location
    Ft Lee
    Posts
    2

    Strange FireFox error

    My page works perfectly in IE, but on firefox I get these super weird errors. I get a new one every second or two and theres no rhyme or reason to what the last letter is (at least as far as i can tell).

    Again, the page works PERFECTLY in Internet Explorer. This is a cross-browser javascript issue, not a server issue. There is no line number or anything so it seems that its coming from a throw. I went through your code to try to change every "throw" to an "alert" but that made no difference.

    The error lines that I have been getting are any of the following three:

    uncaught exception: Permission denied to get property Window.LS_s
    uncaught exception: Permission denied to get property Window.LS_e
    uncaught exception: Permission denied to get property Window.LS_u


    Please let me know what to change.
    -james.

  2. #2
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    Hi,

    Are your pages deployed on an external web server (ie not in Lightstreamer internal web server)?
    Which kind of structure has your application (frames-single frame-iframes)?
    Please take a look to these threads:
    http://www.lightstreamer.com/vb/show...nal+deployment
    http://www.lightstreamer.com/vb/show...nal+deployment

    Let me know if that not helps.

  3. #3
    Member
    Join Date
    Mar 2007
    Location
    Ft Lee
    Posts
    2

    Solution

    In firefox, I need to setDomain to the local domain, while in IE, if I do that, all I get is javascript errors.

    In IE, I need to setDomain(null) in order to get anything to work.

  4. #4
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    If so I assume that your LSHost and domain settings are equals.
    If you can you should change the hostname or the domain in a way that they look different.

    eg:
    domain - lightstreamer.com
    LSHost - push.lightstreamer.com

    this way you will see your app running on both IE and FX

  5. #5
    Member
    Join Date
    Jun 2007
    Location
    Toronto
    Posts
    2

    Works in Firefox not in IE

    Hi,

    My program works in FireFox not in IE. In IE I get Permission Denied on this statement in lsengine.js:

    self.LS_onld=LS_tlB;

    I have set the domain to "local.com" and host to "push.local.com". As a matter of fact I get the same error in the demo pages included in Lightstreamer.

    I use different servers for Lightstreamer and Web Server.

    I appreciate your help.

    Farshid

  6. #6
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    Which URL are you using to access your pages?
    Could you post your PushPage and LightstreamerEngine initialization code?

 

 

Similar Threads

  1. Strange exception
    By Alex Zherdev in forum Client APIs
    Replies: 1
    Last Post: December 1st, 2011, 10:33 AM
  2. Strange Error on item update
    By mnenchev in forum Client APIs
    Replies: 10
    Last Post: March 19th, 2010, 09:57 AM
  3. Firefox 3.x --> error on unload
    By Mone in forum Client APIs
    Replies: 0
    Last Post: September 19th, 2008, 10:33 AM
  4. Firefox 2.0.0.14 error message
    By quanhm in forum Client APIs
    Replies: 1
    Last Post: May 16th, 2008, 04:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 09:24 AM.