Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Power Member
    Join Date
    Sep 2013
    Location
    Coimbatore
    Posts
    112
    Hello,
    I have checked well, in my adapter some times exception only happening. I have handled the exception so there is no issue on that. And I have noticed in browser when rates gets stops. I can confirm LS server is working, adapter is not sending the updates. Please look on this below response of browser developer tool

    var myEnv = lsc;
    var phase = null;
    function setPhase(ph) {
    phase = ph;
    }


    var winPhase = {};
    function setWin(tbl, ph) {
    winPhase[tbl] = ph;
    }


    var clsd = false;
    function c(cod, ph, tbl, its, flds, key, com) {
    LS_window.LS_w(cod, ph, tbl, its, flds, key, com);
    }


    function error(cod, ph, tbl, msg) {
    if (tbl != null) {
    LS_window.LS_l(cod, ph, tbl, msg);
    } else {
    LS_window.LS_l(cod, phase, null, msg);
    }
    }


    function start(sID, addr, kaMs, reqLim, srv, ip) {
    LS_window.LS_e(1, phase, sID, addr, kaMs, reqLim, srv, ip);
    }


    function end(cause) {
    LS_window.LS_e(4, phase, cause);
    }


    function loop(holdMs) {
    LS_window.LS_e(2, phase, holdMs);
    }


    function retry() {
    LS_window.LS_e(3, phase);
    }


    function s0() {}


    function bw(maxBW) {
    LS_window.LS_e(5, phase, maxBW);
    }


    function y(secs) {
    LS_window.LS_s(phase, secs);
    }


    var unchangedSignal = {};
    unchangedSignal.length = -1;
    function convert(b, f) {
    var a, c, d = f, e = [];
    for(a = 0;a < b.length;a++) {
    if(a < f) {
    e[a] = b[a]
    } else {
    if(b[a].charAt) {
    b[a] == '$' ? e[d] = '' : b[a] == '#' ? e[d] = null : (c = b[a].charAt(0), e[d] = c == '$' || c == '#' ? b[a].substring(1) : b[a]), d++
    } else {
    for(c = 0;c < b[a];c++) {
    e[d] = unchangedSignal, d++
    }
    }
    }
    }
    return e;
    }
    function d(tbl) {
    try { LS_window.LS_u(winPhase[tbl], convert(arguments || d.arguments, 2)); } catch(exc) {}
    }
    function z(tbl) {
    LS_window.LS_v(winPhase[tbl], convert(arguments || z.arguments, 2));
    }
    function n(tbl) {
    LS_window.LS_n(winPhase[tbl], arguments || n.arguments);
    }
    function s(tbl) {
    LS_window.LS_s(winPhase[tbl], arguments || s.arguments);
    }
    function r(tbl) {
    LS_window.LS_o(winPhase[tbl], arguments || r.arguments);
    }
    function p() {
    LS_window.LS_u(phase, arguments || p.arguments);
    }
    myEnv.setPhase = setPhase;
    myEnv.setWin = setWin;
    myEnv.c = c;
    myEnv.error = error;
    myEnv.end = end;
    myEnv.start = start;
    myEnv.loop = loop;
    myEnv.retry = retry;
    myEnv.s0 = s0;
    myEnv.bw = bw;
    myEnv.y = y;
    myEnv.convert = convert;
    myEnv.d = d;
    myEnv.z = z;
    myEnv.n = n;
    myEnv.s = s;
    myEnv.r = r;
    myEnv.p = p;
    myEnv.LS_window = LS_window;


    // END OF HEADER


    setPhase(7703);
    start('Scd93873dea9808b9M6deT5148753', null, 5000, 50000);

  2. #12
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    580
    Hi,

    The javascript you showed is the normal reply to a create session request from the client, so it seems ok from that side, and gives us no clue on the actual cause of the issue.
    You should make sure that your data adapter continues to work regularly and push updates into the Lightstreamer server.
    If we're not sure of that it is difficult to further investigate the problem.
    Maybe, when you catch the exception you just discard the update received from the back-end and don't send anything to the server anymore?

    Regards,
    Giuseppe

  3. #13
    Power Member
    Join Date
    Sep 2013
    Location
    Coimbatore
    Posts
    112
    Hi,
    I have monitor from morning, this was working fine but now suddenly stops the response and showing the below thing when it get stopped

    setPhase(34054);start('S10ac9332c76d9c6eMb7dT53073 67', null, 19000, 50000);bw(0.0);setWin(1,1);setWin(2,1);d(2,7,7,'20 20-10-16 19:37:01');d(2,6,7,'2020-10-16 19:37:01');loop(0);end( );


    After this above response not working, below things only happening




    bind_session
    LS_session=S10ac9332c76d9c6eMb7dT5307367&LS_phase= 34322&LS_cause=loop&LS_polling=true&LS_polling_mil lis=0&LS_idle_millis=19000&LS_container=lsc&


    setPhase(34320);start('S10ac9332c76d9c6eMb7dT53073 67', null, 19000, 50000);bw(0.0);setWin(1,1);setWin(2,1);loop(0);end ( );


    bind_session
    LS_session=S10ac9332c76d9c6eMb7dT5307367&LS_phase= 34322&LS_cause=loop&LS_polling=true&LS_polling_mil lis=0&LS_idle_millis=19000&LS_container=lsc&


    setPhase(34322);start('S10ac9332c76d9c6eMb7dT53073 67', null, 19000, 50000);bw(0.0);setWin(1,1);setWin(2,1);loop(0);end ( );


    setPhase(34266);start('S10ac9332c76d9c6eMb7dT53073 67', null, 19000, 50000);bw(0.0);setWin(1,1);setWin(2,1);d(2,1,'5066 9','50687',6);loop(0);end( );


    bind_session
    LS_session=S10ac9332c76d9c6eMb7dT5307367&LS_phase= 34058&LS_cause=loop&LS_polling=true&LS_polling_mil lis=0&LS_idle_millis=19000&LS_container=lsc&


    setPhase(34056);start('S10ac9332c76d9c6eMb7dT53073 67', null, 19000, 50000);bw(0.0);setWin(1,1);setWin(2,1);d(2,4,'24.4 ','24.44',6);loop(0);end( );


    bind_session
    LS_session=S10ac9332c76d9c6eMb7dT5307367&LS_phase= 34056&LS_cause=loop&LS_polling=true&LS_polling_mil lis=0&LS_idle_millis=19000&LS_container=lsc&

  4. #14
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    580
    Hi,

    This is strange, because the browser console reports a regular client polling session, and indeed you can see some data received, such as:

    d(2,1,'5066 9','50687',6)

    and

    d(2,4,'24.4 ','24.44',6)

    So actually the client keeps getting something from the Lightstreamer server.
    Maybe that's not all you expect?
    In this case it is necessary to double check the data in the server log to understand what was actually received by the data adapter and routed to the client.
    In this case you need the DEBUG level for these loggers:

    <logger name="LightstreamerLogger.subscriptions" level="DEBUG"/>

    <logger name="LightstreamerLogger.subscriptions.upd" level="DEBUG"/>

    Regards,
    Giuseppe

 

 

Similar Threads

  1. Replies: 2
    Last Post: August 20th, 2015, 12:41 PM
  2. Replace Adapter without restart of Light Streamer service
    By Slavko Parezanin in forum Adapter SDKs
    Replies: 1
    Last Post: January 19th, 2015, 10:43 AM
  3. Replies: 5
    Last Post: August 20th, 2009, 11:38 AM
  4. Replies: 2
    Last Post: October 17th, 2008, 10:22 AM
  5. Hitting ESC stops streaming
    By Mone in forum Client SDKs
    Replies: 1
    Last Post: April 19th, 2007, 08:42 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 02:35 PM.