Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2010

    Regarding deployment of applications in Red hat Linux

    > Here is the Issue, I designed some basic applications and I programmed the
    > adapters in java on windows vista platform.
    > When I tested them they ran well. Here comes the problem, I am unable run
    > the same applications on Red hat Linux. when I tried to debug my html page
    > .,
    > it is showing an error at the sentence :
    var pushPage = initializeDemoPushPage("./ls", true, onEngineReady, onEngineLost);
    > and the error message is "object expected".
    > "./ls is the location where I placed all of my java script files"
    > Same error is existing for all my applications which were designed on
    > windows.
    > But the demo applications provided by the lightstreamer are running fine on
    > linux.
    > Please help in this issue.
    > Thank you,
    > Best Regards,
    > Sunny

  2. #2
    Join Date
    Jul 2006
    I suppose that the object expected is the "initializeDemoPushPage".
    All demo applications provided by Lightstreamer import the "misc.js" source file,
    which contains the "initializeDemoPushPage" function.
    I suppose that this import fails in your unsuccessful installation;
    please check where you placed "misc.js" and the way you import it.

    Note that the relative path to be supplied to "initializeDemoPushPage" is:
    from the directory which contains your pushpage to the directory which contains misc.js;
    hence, it is the same path you use in the <script> block through which you import "misc.js".

    By the way, this seems not related with Windows or Linux (at least, not in a direct way).



Similar Threads

  1. Single Linux server with 2 IP addresses
    By anselme in forum General
    Replies: 4
    Last Post: March 30th, 2012, 08:37 AM
  2. Linux Production Settings
    By musaulker in forum General
    Replies: 1
    Last Post: December 21st, 2009, 10:02 AM
  3. IG Group's cool applications
    By Alessandro in forum General
    Replies: 6
    Last Post: July 1st, 2008, 02:26 PM
  4. Problem with stopping LS server in Linux
    By quanhm in forum General
    Replies: 1
    Last Post: November 16th, 2007, 11:32 AM
  5. External deployment
    By markgoldin in forum General
    Replies: 6
    Last Post: September 28th, 2007, 01:15 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
All times are GMT +1. The time now is 05:16 AM.