Results 1 to 10 of 24

Hybrid View

  1. #1
    Member
    Join Date
    Jan 2011
    Location
    Plainfield
    Posts
    13

    RTD Demo will not connect to Lightstreamer Server

    Hello,

    We are having some difficulty connecting the RTD server to our Lightstreamer server.

    I've changed the pushServerHost and the pushServerPort in RtdServer.cs as well as added some login credentials using connInfo object (User, Password), however we cannot connect to our Lightstreamer server.

    The UI loads and hangs connecting to the RTD server. Is there anything else necessary to specify to connect or some way to enable more debugging output on our Lightstreamer server to help see if the connection attempt is being made and/or what info is being passed in?

  2. #2
    Member
    Join Date
    Jul 2010
    Location
    Trento
    Posts
    12
    Hi,
    we would like to know more info about your issue.
    First of all, is the RTD server running locally, or is it on a remote computer?

    The demo is meant to be run locally (both server and client).
    If you plan to use a remote RTD server, you need to decouple the server part of the library from the client part, which is actually outside the scope of the demo itself.

    Once you've moved the server part to a separate library, you need to install it on the server machine and register against DCOM (the .dll will be a COM resource).
    Same thing for the client part, you need to write and register it on every client in which your RTD service should be available.

  3. #3
    Member
    Join Date
    Jan 2011
    Location
    Plainfield
    Posts
    13
    Quote Originally Posted by lxnay
    Hi,
    we would like to know more info about your issue.
    First of all, is the RTD server running locally, or is it on a remote computer?

    The demo is meant to be run locally (both server and client).
    If you plan to use a remote RTD server, you need to decouple the server part of the library from the client part, which is actually outside the scope of the demo itself.

    Once you've moved the server part to a separate library, you need to install it on the server machine and register against DCOM (the .dll will be a COM resource).
    Same thing for the client part, you need to write and register it on every client in which your RTD service should be available.
    It is running locally - at this point we are just trying to get the RTD Demor to connect to our Lightstreamer server and receive updates from it.

    From the readme it appears this should be as simple as changing the pushServerHostURL and setting the appropriate port. I've changed this and added some login credentials to the LightstreamerClient.Start method so that it should successfully connect to our Lightstreamer server, but this does not appear to be successful.

    When the UI loads the connection is started but we don't appear to progress past
    Code:
    new ThreadStart(delegate() { lsClient.Start(pushServerUrl); }).Invoke();
    in RtdServer.ServerStart(). I put an output before the call to the Start method and after and we never reach the second output. Excel eventually throws a dialog that it is waiting for another task to complete an OLE operation.

  4. #4
    Member
    Join Date
    Jul 2010
    Location
    Trento
    Posts
    12
    It looks like a network issue (firewall?).
    Please have a look using wireshark and see what's going on at the NIC level.

  5. #5
    Member
    Join Date
    Jan 2011
    Location
    Plainfield
    Posts
    13
    Quote Originally Posted by lxnay
    It looks like a network issue (firewall?).
    Please have a look using wireshark and see what's going on at the NIC level.
    Sorry it took so long to reply - I got caught up doing other things. Firewall is disabled to rule out potential issues there. Wireshark doesn't show a single outgoing packet headed to the server. I've specified the URL as both a FQDN and IP (in case name resolution was failing for some reason) and still don't see any packets heading for the destination as expected.

  6. #6
    Member
    Join Date
    Jul 2010
    Location
    Trento
    Posts
    12
    Just a question and a request, if possible.
    Question: what do you mean with "I've changed this and added some login credentials to the LightstreamerClient.Start method so that it should successfully connect to our Lightstreamer server". What login credentials? Are you talking about HTTP AUTH? Can I have a code snippet that shows how you did that? Are you running behind a proxy? Please note anyway that all this is outside the scope of our, very simple demo.
    Request: Could I have a diff between the demo code and your changes, or alternatively, could you attach your code here?

    Thanks

 

 

Similar Threads

  1. Could not connect to light streamer server
    By bponnappan in forum Adapter APIs
    Replies: 1
    Last Post: July 5th, 2012, 09:38 AM
  2. Replies: 3
    Last Post: November 14th, 2011, 09:33 AM
  3. Connect to LightStreamer with NodeJS
    By afshinmeh in forum Client APIs
    Replies: 1
    Last Post: October 6th, 2011, 06:31 PM
  4. Can't connect to lightstreamer in firefox
    By chuan_ckc in forum Client APIs
    Replies: 9
    Last Post: August 25th, 2009, 05:16 AM
  5. Replies: 1
    Last Post: February 22nd, 2008, 08:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 07:12 PM.