Results 1 to 2 of 2

Hybrid View

  1. #1
    Senior Member
    Join Date
    Jul 2009
    Location
    sofia
    Posts
    40

    itemUpdate.getNewValue throws strange exception

    Hi,

    As i got this strange error TypeError: this.LS_Qfy.LS_WPo is undefined
    i debugged the javascript code i wrote to handle LS updates.
    It seems that itemUpdate.getNewValue(schema[i]) throws this error, where schema[i] is array which contains all schema properties for which the user is subscribed.It seems that this error is always thrown exactly for one concrete prop of the schema properties. Since most of the schema properties are dynamically managed (add/remove on demand) i checked for this one, but it is static, i.e. it is added at initialization time is never removed.
    Any help will be appreciated.

    Thanks.

  2. #2
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    if I remember correctly you're using the client library 4.3.1 build 1355.3

    That's not a problem on a field, what's undefined is the entire collection of values.
    I suppose you're calling the getNewValue method while the table is not pushing.

    If that's the case please note that you can't store the UpdateItemInfo: once the onItemUpdate method is executed the UpdateItemInfo can't be used as the client library will reuse the instance for the next update.

    Also, if you disconnect or remove the table during the onItemUpdate execution but before calling the getNewValue method, then the effect could be the same.

    Also if possible, I suggest you to upgrade the client library to the latest version (that is 4.4.1 build 1396.4)

 

 

Similar Threads

  1. Replies: 7
    Last Post: December 13th, 2011, 04:08 PM
  2. Strange exception
    By Alex Zherdev in forum Client SDKs
    Replies: 1
    Last Post: December 1st, 2011, 09:33 AM
  3. Replies: 0
    Last Post: November 8th, 2011, 09:20 AM
  4. Strange Error on item update
    By mnenchev in forum Client SDKs
    Replies: 10
    Last Post: March 19th, 2010, 08:57 AM
  5. Strange FireFox error
    By jameswolfe in forum Client SDKs
    Replies: 5
    Last Post: August 27th, 2007, 01:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 02:54 PM.