Results 1 to 3 of 3

Threaded View

  1. #1

    Client receiving IndexItem instead of map

    Hi,

    We are using the js client in COMMAND mode with the fields individually specified. On the adapter side, we are pushing the data as a map to the kernel. What is being received at the client is what appears to be an index item list, including the entire list of fields, the field name to index map and then the list of data items, similar to this:

    {"jy":1,"iy":"FLIGHTS","au":false,"ma":{"Zb":null, "sb":24,"list":["key","command","flightNum","depArptCd","formatted SchedDepartureTime","formattedBestDepartureTime"," departureGate","departureStatus","depDelay","arrAr ptCd","formattedSchedArrivalTime","formattedBestAr rivalTime","arrivalGate","arrivalStatus","arrDelay ","jeopPax","incopPax","impactPax","totalPax","run Status","rbkPrct","oaRbkPrct","avgLtns","procTime"],"Cs":{"key":1,"command":2,"flightNum":3,"depArptCd":4,"formatte dSchedDepartureTime":5,"formattedBestDepartureTime ":6,"departureGate":7,"departureStatus":8,"depDela y":9,"arrArptCd":10,"formattedSchedArrivalTime":11 ,"formattedBestArrivalTime":12,"arrivalGate":13,"a rrivalStatus":14,"arrDelay":15,"jeopPax":16,"incop Pax":17,"impactPax":18,"totalPax":19,"runStatus":2 0,"rbkPrct":21,"oaRbkPrct":22,"avgLtns":23,"procTi me":24}},"Od":[2,1,"ZZ592120190602XYZABC","ADD","5921","XYZ","06/02 06:59 PM","06/02 06:59 PM","C32","Routine","00:00","ABC","06/02 08:23 PM","06/02 09:13 PM","A4","Routine","00:50","--","--","--","--","NEW","--","--","--","--"]}

    Is there any way to coerce the data back into the map or do we have to do that by hand on the client side?

    There is another point of confusion, as well, in that the specified index values appear to be one number off. For instance, above, we see "key" : 1, but in the Od list, the key is actually the third field (index 2). How would we reconcile that?

    Thanks,
    Paul
    Last edited by paulwiersema; June 3rd, 2019 at 03:08 AM.

 

 

Similar Threads

  1. Replies: 5
    Last Post: December 23rd, 2010, 09:34 AM
  2. Replies: 3
    Last Post: February 12th, 2009, 11:31 AM
  3. Replies: 2
    Last Post: May 15th, 2008, 10:25 AM
  4. Replies: 5
    Last Post: February 22nd, 2008, 11:37 AM
  5. Web client not receiving any data?
    By TonyRoberts in forum Client APIs
    Replies: 10
    Last Post: October 10th, 2007, 10:00 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 12:20 AM.