Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Jul 2009
    Location
    Colorado Springs
    Posts
    8

    Question Lightstreamer fails to start when run as a service

    Greetings,

    In our development we have started lightstreamer as a console application using the file Start_LS_as_Application.bat. This works fine. However, if we attempt to run Start_LS_as_service-NT.bat I can see that the bat file correctly installs the service with Windows (SC). You can see that the service has been installed and is in a stopped state.

    If you attempt to start the service (service control pannel or by exec "SC Start Lightstreamer" the service fails to start. The following error message is displayed,
    "Could not start lightstreamer service service on local computer Error 1067: The process terminated unexpectedly".

    The System event log also reveils that SC has successfully sent a "Start Control" to the service and I also have the above error message entry as well.

    Is there something I need to do more to install Lightstreamer as a service, i.e., what files are needed? Where is the java wrapper looking for the files?

    Thanks in advance,
    Best Regards,
    Peter Hiross

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    973
    All the files and other resources needed are reported in the wrapper.conf file under the "conf" directory.
    Did the Server log anything?
    If not, can you see any console output from the Server in the wrapper's own log file?

    Also note that the included version of the "java service wrapper" has some limitations. For instance, it does not support 64bit windows; you may use sc.exe in those cases.

    [NOTE the new wrapper included with Lightstreamer 4 now supports 64 bit machines out of the box]

  3. #3
    Member
    Join Date
    Jul 2009
    Location
    Colorado Springs
    Posts
    8

    Smile

    Thanks got it working. Needed to set the java path on the config file.

 

 

Similar Threads

  1. .NET web service as Data Feed
    By icaiozzi in forum Adapter APIs
    Replies: 1
    Last Post: November 19th, 2010, 11:52 AM
  2. Server start fails on Windows
    By UweF in forum General
    Replies: 1
    Last Post: November 19th, 2010, 11:41 AM
  3. DataAdapter Service
    By brucehoch in forum Adapter APIs
    Replies: 3
    Last Post: October 14th, 2010, 11:22 PM
  4. How to deploy on a web hosting service ?
    By mohamida in forum General
    Replies: 8
    Last Post: May 24th, 2010, 11:39 AM
  5. Lightstreamer will not start unattended
    By jeffdyer in forum Adapter APIs
    Replies: 2
    Last Post: November 2nd, 2009, 08:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 05:39 AM.