Results 1 to 9 of 9
  1. #1

    Question Client-Server compatibility

    Hi.
    I work with service that uses Lightstreamer/5.1.1 build 1623.2. Our application include DotNetClient_N2 2.1.
    We encountered a bug that was fixed in 3.0.0 version of .NET PCL Client SDK, but changelog says that client
    Compatible with Lightstreamer Server since 6.1


    Nevertheless, I tried to use it with Lightstreamer/5.1.1 and app worked correct at first glance.

    So, my question is: what problems can I face if I use new client (v.3.0.0 or higher) with old server (v5.1.1).
    Last edited by Vadim Moskvin; December 12th, 2018 at 06:58 AM.

  2. #2
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    537
    Hi Vadim,

    Indeed, I can confirm that .NET PCL Client 3.0.0 is incompatible specifically with the 6.0.x servers but should work fine with 5.x family servers.
    This is because the new client version checker introduced with 6.0 that rejects the new PCL Client SDK.

    So to recap, you can still use version PCL client 3.0.0 with your current server version, but you should be aware that you will have problems if the server is upgraded to version 6.0.
    But considering that the 5.1.1 version is already very old I think it would make more sense to move directly to 7.0 (or at least 6.1).

    Please let us know if you need any further clarifications.

    Regards,
    Giuseppe

  3. #3
    Thanks for your prompt reply.

    Indeed, I can confirm that .NET PCL Client 3.0.0 is incompatible specifically with the 6.0.x servers but should work fine with 5.x family servers.

    What can you say about the client v3.1.1. Can we use it with 5.x family servers?

  4. #4
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    537
    No, since 3.1.0 the PCL client introduced the session recovery mechanism that is supported only by Lightstreamer server 7.0.

  5. #5
    Thanks for the clarification.

  6. #6
    Another question.
    The service is soon moving to the Lightstreamer-Server/7.0.1 version. Do I understand correctly that .NET PCL Client 3.0.0 can work with both versions: Lightstreamer/5.1.1 and Lightstreamer-Server/7.0.1?

  7. #7
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    972
    Yes. Newer Server versions are always backward compatible with older Client SDK versions.
    To resume the case of .NET PCL Client 3.0.0, it was introduced together with Server version 6.1, so:
    • It works with Server versions 6.1 and above.
    • Regarding preexisting Server versions, it happens to be compatible with Server versions 5.1.x but not with 6.0.

  8. #8
    Hi guys. Thanks for your great job and cool product. Just another question about compatibility. In our android application we use ls-android-client lib ver. 1.0.2 with LS server ver. 5.1.1. Our server guys are redy to migrate to Lightstreamer-Server ver. 7.0.1. So, may we continue to use our old ls-android-client lib (1.0.2) with new Lightstreamer-Server ver. 7.0.1?
    Or we will be get some compatibility issues?
    What version of ls-android-client lib do your recomended in this case?

  9. #9
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    537
    Hi,

    As a rule of thumb newer Lightstreamer servers usually support older clients; this allows our customers to go live in production with the new server version and old clients.
    In your specific case I can confirm that your Android client based on lib 1.0.2 should work fine with Lightstreamer 7 without any changes.

    In any case, since Android 1.0.2 is quite old and out of support, and in order to take advantage of all the enhancements and bug fixes introduced in newer versions we strongly recommend to upgrade at your earliest convenience to the new Android lib version 4.0 (https://www.lightstreamer.com/api/ls...client/4.0.12/).

    Regards,
    Giuseppe

 

 

Similar Threads

  1. Client compatibility with older servers [iOS]
    By BruceWayne in forum Client APIs
    Replies: 1
    Last Post: January 27th, 2016, 08:53 AM
  2. SSL certificate compatibility list
    By anselme in forum General
    Replies: 6
    Last Post: February 12th, 2013, 03:46 PM
  3. BlackBerry OS compatibility
    By ulises.juarez in forum Client APIs
    Replies: 6
    Last Post: October 24th, 2011, 09:39 AM
  4. MOBILE DEVICES: add your compatibility test here
    By Alessandro in forum Client APIs
    Replies: 7
    Last Post: May 8th, 2011, 10:26 AM
  5. MOBILE DEVICES: add your compatibility test here
    By Alessandro in forum Client APIs
    Replies: 2
    Last Post: October 6th, 2009, 09:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 11:32 AM.