Results 1 to 3 of 3
  1. #1

    Question iOS Unified Client questions

    Hello,

    I am using an older version of the Lightstreamer iOS Client (1.4.3) and I want to update to the latest one. I saw that the newest version of the Native iOS Client is 1.4.5, but the most recent version for the Unified Client is 3.0.1. Is there a major difference between the two?

    I am already linking an old version of j2objc, can you tell me what version you are using for the unified client?

    I saw in this post https://github.com/Lightstreamer/Lig...-java/issues/3 that you will make the java client open source, yet I did not find it anywhere. Is it possible to get hold of the sources so I could compile them with my version of j2objc? If not, can I get a version of the iOS Unified Client that doesn't link j2objc?

    Thank you,
    Radu Carlig

  2. #2
    Administrator
    Join Date
    Feb 2012
    Location
    Bologna, Italy
    Posts
    93
    Hello Radu,

    the main new feature of version 3.0.1 is support for WebSocket, but it also adds numerous minor improvements and fixes, compared to version 2.x. Moreover, as you already know, compared with 1.x it adopts the "Unified API" model: a common API shared by clients of all major platforms (in particular Java/Android and JavaScript/Web).

    Regarding J2ObjC, iOS Client 3.0.1 uses version 2.0.3 of J2ObjC. Anyway, theoretically, it should not interfere with your app, since the iOS Client is packaged as a framework (not a static library). We haven't tried it, so let us know if any issue should arise.

    At the moment we don't have a version of the iOS Client that supports both the Unified API and doesn't use J2ObjC. The latest version that doesn't use J2ObjC is 1.4.5, as you noted.

    Trans-compiling the source code of the Java client on your own is discouraged. We make heavy use of dependency injection to add features like native network transport, WebSocket support, network status monitoring, etc. Bare transpilation can only provide an incomplete and underperforming product.

    Hope this helps. Let us know if you need further information.
    Best regards,

    Gianluca

  3. #3
    Thank you for your answers. For the moment I will update to 1.4.5 as it is easier and faster, but I am planning on updating to 3.0.1 in the near future. I will let you know how that goes.

    Cheers,
    Radu

 

 

Similar Threads

  1. Connection timed out on empty credentials on iOS [iOS]
    By Anatoly Gurfinkel in forum Client APIs
    Replies: 9
    Last Post: July 6th, 2015, 05:24 PM
  2. Replies: 4
    Last Post: February 27th, 2015, 07:58 AM
  3. Some basic questions about LS
    By reutoren in forum Client APIs
    Replies: 1
    Last Post: December 14th, 2011, 11:27 AM
  4. LS load balancing Option 1.A.2 questions?
    By dimitarn in forum General
    Replies: 1
    Last Post: March 29th, 2010, 07:28 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 07:24 AM.