Results 1 to 2 of 2

Thread: adapters.xml

  1. #1
    Member
    Join Date
    Aug 2009
    Location
    Noida
    Posts
    26

    adapters.xml

    Hi,

    I upgraded LS 3.4 to LS 3.6, On subscribing from client, LS was showing message "Refused request: Requested nonexistent default Data Adapter for ION2 from 192.168.45.13:1244"

    since in client adapter name has not been set , yet with LS 3.4 it work fine.

    does it mean LS3.4 assume a default adapter and LS 3.6 need explicitly adapter name?
    Is there a way to configure default adapter name in adapter.xml for LS 3.6 so that LS client only need to mentioned adapters_conf id and can leave to set adapter name?
    Pradeep Kr Chahal
    Software Designer
    Expertise in implementing Market Interface, Push technology, Publish-Subscribe Architecture
    pkumar.chahal@gmail.com
    http://www.pradeepchahal.com

  2. #2
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    I guess that you're now using multiple data adapters (<data_provider>) inside a single adapters.xml

    each <data_provider> element should now include a name, if such property is missing the DEFAULT name is used.

    each table on the client should specify a data adapter, if not specified DEFAULT is used.

    So you should name one of your <data_provider> elements as DEFAULT or specify on the table the data adapter in use.

    HTH

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 06:32 PM.