Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Mar 2010
    Location
    middletown
    Posts
    1

    Unhappy Issue with HelloWorld

    Hi I am new to lightstreamer...my questions is:
    I am using
    <div source="lightstreamer" table="hellotable" item="greetings" field="message">loading...</div>
    <div source="lightstreamer" table="hellotable" item="greetings" field="timestamp">loading...</div>
    <div source="lightstreamer" table="hellotable" item="greetings" field="newitem">loading...</div>
    and in my DataAdaptor I do this:
    Map<String, String > data = new HashMap<String, String >();
    data.put("message", c % 2 == 0 ? "Hello" : "World");
    data.put("timestamp", new Date().toString());
    data.put("newitem", c % 2 == 0 ? "NewItem" : "oldItem");
    listener.smartUpdate(itemHandle, data, false);
    However, only two of the fields show up on the screen? Where is the binding between the fields and the subscription? how do you add new fields?
    Thanks in advance,
    Alex
    http://www.lightstreamer.com/vb/imag...lies/smile.gif

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    972
    The fields to be requested in the subscription are defined in the table constructor.
    However, if nulls are supplied, as in the HelloWorld example
    var pushtable = new OverwriteTable(null, null, "MERGE");
    the library looks for the fields reported in the available cells when addTable is invoked.
    So, we can't explain why your new field is not managed.
    Can you confirm that you didn't change the line above?

    To shed more light, please show us the Server log, after setting the priority of the LightstreamerLogger.subscriptions category as DEBUG.

 

 

Similar Threads

  1. HelloWorld help needed
    By jim.macaulay@lbi.com in forum Adapter APIs
    Replies: 4
    Last Post: January 6th, 2012, 10:57 AM
  2. hosting helloworld example on different webserver
    By rbg001 in forum Client APIs
    Replies: 3
    Last Post: May 25th, 2011, 02:11 PM
  3. HELLOWORLD.DEFAULT init error
    By amoroso@forex.co.ke in forum Adapter APIs
    Replies: 3
    Last Post: February 1st, 2010, 11:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 03:41 AM.