Results 1 to 2 of 2
  1. #1
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    970

    Known issues in version 4.4

    The following post is obsolete, as the issue was fixed with library version 4.4.1

    <OBSOLETE>
    A bug has, unfortunately, been introduced in showValues.

    The effect is that the supplied field-value associations are managed in a wrong way in the related invocation of the onChangingValues callback,
    though the only impact is on the behavior of getServerValue, when invoked on the received VisualUpdateInfo object.

    Actually, the value related to the field that precedes (according to the current schema) the one specified is returned.
    The bug occurs regardless that the fields (either in showValues or in getServerValue) are specified by name or by number.

    Hence, the only temporary workaround feasible is to supply the name of the next field (or the field number increased by 1) in place of the requested one. Using the number also allows for getting the value of the last field.
    However, only VisualUpdateInfo objects originated by showValues are affected: objects that carry normal updates from the Server are not affected.
    Note that setFormattedValue is also not affected, so the correct field name should be specified there.
    </OBSOLETE>

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    970
    The following issue introduced in version 4.4 affects showValues.

    Despite one should be able to call showValues at any time during the lifetime of a table (i.e. after addTable and before removeTable),
    the call will be refused in case the Engine is currently disconnected or still connecting and an exception will be thrown to the caller.

    Hence, any use of showValues as a means to populate the table at startup will probably fail with an exception.
    On the other hand, any use of showValues to modify a table while data is coming will work, but it might throw an exception as well, as soon as a disconnection occurred.

 

 

Similar Threads

  1. JVM version
    By Waddy in forum General
    Replies: 3
    Last Post: March 12th, 2013, 08:53 AM
  2. .net version for messenger
    By jeane@jse.co.za in forum Adapter APIs
    Replies: 3
    Last Post: February 23rd, 2011, 09:22 AM
  3. Connectivity issues
    By mve.autocom in forum Client APIs
    Replies: 1
    Last Post: December 3rd, 2010, 09:37 AM
  4. JVM version
    By rmoura in forum General
    Replies: 1
    Last Post: September 28th, 2010, 11:17 AM
  5. Replies: 1
    Last Post: April 26th, 2007, 01:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 01:21 PM.