Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Mar 2010
    Location
    Rio de Janeiro
    Posts
    3

    Exclamation PushServerException: "No more answer from server"

    Hi all,

    I am trying to adapt your .NET Client Demo to my needs. For now, I just want it to connect to my client's adapter (it's working correctly) and return data to the grid.

    Sometimes, it does it perfectly, but sometimes it just keep saying "Lightstreamer is pushing (smart pooling mode)" and after some time, it throws me "PushServerException: No more answer from server".

    While sniffing the requests, I've come to this response while it was pushing:

    Request:
    Code:
    LS_user=####&LS_password=####&LS_adapter_set=TestQuote&LS_content_length=50000000&LS_report_info=true
    Response:
    Code:
    OK
    SessionId:Se7cd01101430b301T0234433
    KeepaliveMillis:2000
    MaxBandwidth:0.0
    RequestLimit:50000
    ServerName:Lightstreamer HTTP Server
    
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE
    PROBE

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    The .NET client library (I assume you are using the latest version, i.e. 1.4) opens a smart polling session after a previous attempt to open a streaming connection has received no answer.
    This is usually because of a buffering proxy in the middle;
    however, in that case, all attempts of opening a streaming session would fail.

    In your case, you may be experiencing a different kind of connection problems, which affects only a part of the connection attempts.
    Note that the "No more answer from server" message is also caused by a connection problem, when a poll returns but the subsequent one does not yield any answer.
    Also note that the reported successful streaming session still yields no data; perhaps, the subscription request has failed to connect as well?

    Information on the whole client-server interaction is needed to shed light on this behaviour.
    At least, a comparison of the Server log (with default log settings), taken during a successful and an unsuccessful run.

  3. #3
    Member
    Join Date
    Mar 2010
    Location
    Rio de Janeiro
    Posts
    3
    I am trying to connect to a remote lightstreamer host.
    When I test my application localy, it works fine.

    All requests return OK from the server, but sometimes it returns data and sometimes don't and then, after some time, it closes the connection with that "No more answers from server" error.

    I don't have access to the server log, but I'll try to get it.

 

 

Similar Threads

  1. Replies: 1
    Last Post: July 10th, 2012, 07:06 PM
  2. Replies: 2
    Last Post: March 1st, 2012, 02:53 PM
  3. Replies: 3
    Last Post: February 19th, 2010, 12:14 AM
  4. Replies: 1
    Last Post: September 18th, 2009, 10:13 AM
  5. Incorrect Answer - PushServerException
    By RichP1 in forum Client APIs
    Replies: 1
    Last Post: February 26th, 2009, 10:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 07:12 PM.