Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Jun 2009
    Location
    Copenhagen
    Posts
    2

    swfaddress and IE7

    swfaddress ( http://www.asual.com/swfaddress/ ) does not work with a lightstreamer page in IE7. Everything works fine with IE8 and Firefox.


    To test it, get the "swfaddress.js" file from the distribution
    http://dfn.dl.sourceforge.net/source...s-2.3-dist.zip
    and put it in the "ls" directory of one of the built in example pages (I used \pages\StockListDemo_Basic). Then link to the js file in the index.html header along with the two Lightstreamer js files. Then using either IE7 or IE8's compatability mode to view the page will show that Lightstreamer stops working.

    Is there a way to circumvent this problem? or is use of this js library discouraged?


    Thanks

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan, Italy
    Posts
    517
    Hi Anders,

    We are not familiar with this library.

    Is there any specific error you observe on IE7?

    We will try to replicate the issue, but probably not in the very short term.

    Thanks
    Alessandro

  3. #3
    Member
    Join Date
    Nov 2008
    Location
    København Ø
    Posts
    5
    Thank you for replying

    swfaddress.js is sometimes used in conjunction with a flash object to add settings parameters dynamically to the URL of the page. That is what we use it for. The library is almost always used together with the swfobject library ( http://code.google.com/p/swfobject/ ) for adding flash objects dynamically to the page.

    In terms of errors I have very little to go on, other than an "unknown exception" in lsengine.js


    As said above everything works in IE8 and Firefox, just not in IE7

    It is not an urgent matter but if you get time to replicate the error at some point I would appreciate any input you might have.

    Thanks

  4. #4
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    hi,

    it seems that on IE divs are substituted in some way by the swfaddress library, maybe due to some side effect.

    try this testcase


    we have basically the same problem within our libraries.

    This solves the issue:


    unfortunately I'm not sure it would be so easy to fix it from our side.
    Btw just delay the execution of Lightstreamer-related code should do the trick.

    let me know what you think.
    Cheers

  5. #5
    Member
    Join Date
    Jun 2009
    Location
    Copenhagen
    Posts
    2
    Thanks for taking a look


    both those code snippets seems to work for me in IE7 and IE8.
    We will try to phase out the use of this library. Anyway if anyone else has problems in IE7 only, swfaddress might be it.



    closed

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 12:54 AM.