Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Aug 2009
    Location
    Bangalore
    Posts
    2

    Could not find the main class: com.lightstreamer.LS. Program will exit.

    Sir,

    While starting the server i am gettting the below error, please help

    ./start.sh run
    Starting Lightstreamer Server...
    Please check logs for detailed information.
    /home/selenium/jdk1.6.0_11/bin/java -server -Xms64M -Xmx512M -cp /home/selenium/LightStreamer/lib/lightstreamer.jar:/home/selenium/LightStreamer/lib/ls-adapter-interface.jar:/home/selenium/LightStreamer/lib/ls-monitor.jar:/home/selenium/LightStreamer/lib/log4j-1.2.15.jar:/home/selenium/LightStreamer/lib/jmxri.jar:/home/selenium/LightStreamer/lib/jmxremote.jar:/home/selenium/LightStreamer/lib/jmxremote_optional.jar:/home/selenium/LightStreamer/lib/jmxtools.jar -Dlightstreamer.native.path=/home/selenium/LightStreamer/lib/native com.lightstreamer.LS /home/selenium/LightStreamer/conf/lightstreamer_conf.xml
    Exception in thread "main" java.lang.NoClassDefFoundError: com/lightstreamer/LS
    Caused by: java.lang.ClassNotFoundException: com.lightstreamer.LS
    at java.net.URLClassLoader$1.run(URLClassLoader.java: 200)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.j ava:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:3 07)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:2 52)
    at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:320)
    Could not find the main class: com.lightstreamer.LS. Program will exit.

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    973
    The com.lightstreamer.LS class is included in
    /home/selenium/LightStreamer/lib/lightstreamer.jar.
    Please check that the path is accessible and the jar is not corrupted.

  3. #3
    Member
    Join Date
    Aug 2009
    Location
    Bangalore
    Posts
    2
    Thanks, its working fine now

 

 

Similar Threads

  1. Error with class SimpleTableInfo
    By haison in forum Client APIs
    Replies: 1
    Last Post: October 26th, 2010, 08:52 AM
  2. Silverlight Beta-Test Program
    By Alessandro in forum Client APIs
    Replies: 8
    Last Post: June 21st, 2010, 02:42 PM
  3. Replies: 1
    Last Post: May 21st, 2009, 09:41 AM
  4. LS thread hangs on process exit
    By bartol82 in forum Adapter APIs
    Replies: 3
    Last Post: October 20th, 2008, 02:01 PM
  5. create .jar with .class
    By khalil78 in forum Adapter APIs
    Replies: 2
    Last Post: April 4th, 2008, 07:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 07:46 AM.