Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Feb 2009
    Location
    KL
    Posts
    29

    form POST method vs GET method

    Hi

    I have put the Lightstreamer server to my production server to perform a Live testing and I have discovered an issue which is related to the processing speed.

    After gone through few days of testing and observation (with Lightstreamer impemented), our team discovered that by using form POST method to redirecting to another page takes up more processing time. For example, when user logging in, redirecting user to a log-ined page takes very long time, even time out.

    Later on after we changed to form GET method, the situation turns better. We are not sure where is the problem came from and whether is it caused by the Lighstreamer server. But this problem happened after Lightstreamer has implemented on our production server.

    We are wondering does Lightstreamer takes up more bandwidth when maintaining session with the web client? Does anyone experience this issue before?

    Currently the Lightstreamer server is located in the same machine with our web server due to the domain name issue. we try to assign a sub domain to the Lightstreamer server but we get a permission denied message when the web client trying to establish a connection to the Lightstreamer server that on another machine (e.g: web domain: www.abc.com; Lightstreamer server: push.abc.com).

    Any comment will be appreciated. Thanks.
    Chuan

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan, Italy
    Posts
    517
    Hi Chuan,

    This issue doesn't seem to be related to Lightstreamer.

    Regarding the domain configuration, let's continue the discussion here: http://www.lightstreamer.com/vb/show...=2107#post2107

 

 

Similar Threads

  1. shutdown method of DataProvider?
    By pluczak in forum Adapter APIs
    Replies: 5
    Last Post: April 16th, 2018, 05:26 PM
  2. Replies: 5
    Last Post: May 14th, 2012, 02:47 PM
  3. Replies: 10
    Last Post: July 15th, 2009, 11:02 AM
  4. Data Provider Protocol Method Tags
    By juls in forum Adapter Protocol
    Replies: 1
    Last Post: March 4th, 2009, 10:00 AM
  5. Data Adapter's subscribe() method not getting called
    By CitiMan in forum Adapter APIs
    Replies: 8
    Last Post: November 30th, 2006, 05:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 10:26 PM.