Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Aug 2009
    Location
    Stamford
    Posts
    3

    System.Security.SecurityException

    Hi when i try to run this example/demo
    I get a System.Security.SecurityException, The LightStreamer server and the client is running on the same local computer
    Please advise

    Session initiation failed: Connection to Server failed Lightstreamer.DotNet.Client.PushConnException: Security exception ---> System.Net.WebException: Security exception ---> System.Security.SecurityException ---> System.Security.SecurityException: Security error. at System.Net.Browser.BrowserHttpWebRequest.InternalE ndGetResponse(IAsyncResult asyncResult) at System.Net.Browser.BrowserHttpWebRequest.<>c__Disp layClass5.<EndGetResponse>b__4(Object sendState) at System.Net.Browser.AsyncHelper.<>c__DisplayClass2. <BeginOnUI>b__0(Object sendState) --- End of inner exception stack trace --- at System.Net.Browser.AsyncHelper.BeginOnUI(SendOrPos tCallback beginMethod, Object state) at System.Net.Browser.BrowserHttpWebRequest.EndGetRes ponse(IAsyncResult asyncResult) at Lightstreamer.DotNet.Client.HttpProvider.ReadCallb ack(IAsyncResult asynchronousResult) --- End of inner exception stack trace --- at Lightstreamer.DotNet.Client.HttpProvider.DoHTTP(Bo olean isPost) at Lightstreamer.DotNet.Client.HttpProvider.DoHTTP(ID ictionary parameters, Boolean isPost) at Lightstreamer.DotNet.Client.PushServerTranslator.C allSession() at Lightstreamer.DotNet.Client.PushServerProxy.Connec tForSession() --- End of inner exception stack trace --- at Lightstreamer.DotNet.Client.PushServerProxy.Connec tForSession() at Lightstreamer.DotNet.Client.ServerManager..ctor(Co nnectionInfo info, IConnectionListener listener, IServerListener asyncListener) at Lightstreamer.DotNet.Client.LSClient.OpenConnectio n(ConnectionInfo info, IConnectionListener listener) at Lightstreamer.DotNet.Client.LSClient.OpenConnectio n(ConnectionInfo info, IConnectionListener listener) at TestApplication.MainPage.Connect()

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Is your xap file requested by the browser to an external Web Server?
    In that case, the configuration of a "clientaccesspolicy.xml" file on Lightstreamer Server may still be needed.
    See <silverlight_accesspolicy_enabled> in the example configuration file for the 3.5.1 Server package.

  3. #3
    Member
    Join Date
    Aug 2009
    Location
    Stamford
    Posts
    3
    i have the ClientAccessPolicy.xml and CrossDomain.xml in my C:\Lightstreamer\bin\windows and C:\Lightstreamer\conf dir , both these file have have been configured to access all

    The silverlight_accesspolicy_enabled is set to Y
    and what should be the silverlight_accesspolicy_path set to ?
    Are my xml in the right path ?

    As stated my Lightstreamer and my client run on the same computer


    Please advise


    --- ClientAccessPolicy.xml---
    <?xml version="1.0" encoding="utf-8"?>
    <access-policy>
    <cross-domain-access>
    <policy>
    <allow-from http-request-headers="*">
    <domain uri="*"/>
    </allow-from>
    <grant-to>
    <resource path="/" include-subpaths="true"/>
    </grant-to>
    </policy>
    </cross-domain-access>
    </access-policy>

    -----CrossDomain.xml-----

    <?xml version="1.0"?>
    <!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
    <cross-domain-policy>
    <allow-http-request-headers-from domain="*" headers="*"/>
    </cross-domain-policy>

  4. #4
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    To make sure that it is a configuration issue,
    try asking for /clientaccesspolicy.xml to your Lightstreamer Server and see if you get your file
    (for instance, http://push.lightstreamer.com/clientaccesspolicy.xml yields the one on our demo site).

 

 

Similar Threads

  1. Security patterns: Forcing disconnection
    By churrusco in forum General
    Replies: 15
    Last Post: April 20th, 2010, 09:46 AM
  2. Streaming system is disconnected
    By ivailo in forum Client APIs
    Replies: 2
    Last Post: December 1st, 2009, 01:07 PM
  3. Internet Explorer --> Security zones issue
    By Mone in forum Client APIs
    Replies: 0
    Last Post: July 30th, 2009, 10:09 AM
  4. .Net Messaging system - meta and data adapter linking
    By paul.syson@internova.co.u in forum Adapter APIs
    Replies: 6
    Last Post: March 24th, 2009, 10:13 AM
  5. Replies: 1
    Last Post: February 1st, 2008, 02:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 05:32 PM.