Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Feb 2009
    Location
    KL
    Posts
    29

    Pushing data through secure connection (https protocol)

    Hi,

    I have deployed my push script and Lightstreamer server according to GETTING_STARTED.txt. Everything working fine when the data is push through normal http connection, but when switched to using the HTTPS protocol, the push page become unresponsive. The windows status of the push page keep showing "Lightstreamer is connecting...". When the Lightstreamer server try to push data to the push page, it shows nothing and no response.

    Is there anything I need to configure/change in order to pushing data through HTTPS protocol. Anyone please help me to solve this problem. I will be very appreciated. Thank you.

    Chuan

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    As a first check, have you configured Lightstreamer Server for accepting connections in https?
    This is done through an <https_server> element in lightstreamer_conf.xml.
    Can you access the home page of Lightstreamer Server in https through a browser?

  3. #3
    Member
    Join Date
    Feb 2009
    Location
    KL
    Posts
    29
    Quote Originally Posted by DarioCrivelli
    As a first check, have you configured Lightstreamer Server for accepting connections in https?
    This is done through an <https_server> element in lightstreamer_conf.xml.
    Can you access the home page of Lightstreamer Server in https through a browser?
    Hi Dario,

    Thanks for your reply. I don't see the <https_server> element in the lightstreamer_conf.xml file so I added into it as <http_server> element. But when I start the server, it gave me a message "SSL server not available with the current license"

    FYI, the license I'm using currently was the free version. Does it means that the free version does not support SSL server?

    Thanks.

  4. #4
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Yes, SSL is not supported by the Moderato version.
    You can test SSL connections by downloading the Allegro/Presto/Vivace version and getting an eval license,
    which is free but with some limitations, as summarized here.

  5. #5
    Member
    Join Date
    Feb 2009
    Location
    KL
    Posts
    29
    Quote Originally Posted by DarioCrivelli
    Yes, SSL is not supported by the Moderato version.
    You can test SSL connections by downloading the Allegro/Presto/Vivace version and getting an eval license,
    which is free but with some limitations, as summarized here.

    Thanks Dario, I will try on it.

 

 

Similar Threads

  1. Replies: 1
    Last Post: July 12th, 2010, 11:05 AM
  2. Replies: 1
    Last Post: March 11th, 2010, 04:53 PM
  3. Pushing complex data structure
    By shreyaspurohit in forum Adapter APIs
    Replies: 4
    Last Post: March 30th, 2009, 12:06 PM
  4. Data Provider Protocol Method Tags
    By juls in forum Adapter Protocol
    Replies: 1
    Last Post: March 4th, 2009, 10:00 AM
  5. Bandwidth and event pushing
    By churrusco in forum General
    Replies: 10
    Last Post: May 8th, 2007, 03:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 04:14 PM.