Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Jun 2009
    Location
    Mortlake
    Posts
    5

    WARN: Updated discarded for item ?

    I'm having a problem sending an update to a client by the IItemEventListener.Update method. I'm passing as itemName the same string (in this case "188") that was earlier passed to the Subscribe method. The itemEvent parameter is a simple Dictionary (see below) and the isSnapshot parameter is set to false.

    However I'm not seeing the right data being sent in the HTTP stream - it shows only "<script>d(1,1,1,"#");</script>" and the log has the following message: "Update discarded for item 188"

    The table is set to operate in RAW mode so I think any values that I send to Update should be sent to the client?

    The itemEvent parameter is the following:
    new Dictionary<string, string>() {
    {"value1", "1"},
    {"value2", "craig"}
    };

    Any help is appreciated, thanks!

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan, Italy
    Posts
    517
    Hi,

    Are you sure item 188 is still subscribed to by at least one client when you inject the update from the Adapter?

    Cheers,

    Alessandro

  3. #3
    Member
    Join Date
    Jun 2009
    Location
    Mortlake
    Posts
    5
    I'm pretty sure it's still subscribed - the Unsubscribe method is not being called before I call Update.

    Also, from the .Net side I see the following in the log. I don't know if it helps.

    33775 [1496] DEBUG Lightstreamer.DotNet.Server.RequestReply.NotifySen der (null) - Notify line: 1248872819081|UD3|S|188|S
    |100000122c6d583bd|B|0|S|value1|S|1|S|value2|S|cra ig

  4. #4
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    hi,


    depending on the client version in use that string could represent an update for a table that has two fields, one valued as 1 and the other valued as null, OR, a table with a single field which value is null. Which is the build number of the web client you're using?

    Code:
    1248872819081|UD3|S|188|S
    |100000122c6d583bd|B|0|S|value1|S|1|S|value2|S|craig
    this is your update as it flows from the remote adapter to the server as described by the ARI protocol. Nothing strange here.


    Is it possible that your client is subscribing to the correct item but with the wrong schema?
    Is the WARN message on the server continuously logged?
    Can you check the communication between client and server?

    If is it possible please attach here a server log snippet that shows the issue.

  5. #5
    Member
    Join Date
    Jun 2009
    Location
    Mortlake
    Posts
    5
    Yes, the problem was that I had incorrectly implemented my overrides of the GetItems and GetSchema methods of the MetadataProviderAdaptor. I have it working, though I now have a different problem that I will start a new thread for.

 

 

Similar Threads

  1. Replies: 1
    Last Post: April 17th, 2012, 10:19 AM
  2. Replies: 2
    Last Post: December 24th, 2010, 08:51 AM
  3. warn connections, lightstreamer not run
    By quanghung221 in forum Adapter APIs
    Replies: 1
    Last Post: May 31st, 2010, 10:00 AM
  4. < WARN> Unexpected null event ???
    By mohamida in forum Adapter APIs
    Replies: 2
    Last Post: December 10th, 2009, 07:57 AM
  5. Get <WARN> message: Reply too late.
    By aikobit in forum Adapter APIs
    Replies: 9
    Last Post: July 8th, 2008, 02:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 07:37 PM.