Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27
  1. #21
    Administrator
    Join Date
    Feb 2008
    Location
    Siracusa
    Posts
    153
    Hi Antonio,

    please have a look here.

    Our recommendation is to specify all VM Arguments, in order to avoid any issue you may have with class loading.

    Thanks and Regards,
    Gianluca

  2. #22
    I have created grouped adapters in eclipse and when trying to deploy adapters getting "No plugin found for prefix 'adapter' Imran Khan in the current project".Nawaz Sharif Is there any option in eclispe to deploy all adapters. If so could you please share steps how to deploy multiple adapters using eclipse IDE instead of CLI.
    Last edited by micro123456; February 6th, 2019 at 12:02 PM.

  3. #23
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    543
    Hi,

    The instruction provided in the original post by Gianluca should work also in your case, when multiple adapters are involved.
    Please consider that point 3., "Develop the custom Adapter Set", actually provides the possibility of developing many adapters, to be precise, each Adapter Set can contain only one Metadata Adapter but many Data Adapters.

    Please could you explain better what you mean by " grouped adapters"? Could you also a little expand an the steps you followed?

    Regards,
    Giuseppe

  4. #24
    Although I have had my adaptors and eclipse and lightstreamer all working previously on my Desktop I have moved everything ( via Mercurial ) to a laptop so I can take advantage of some rare UK sunshine.

    For the life of me I can't get Lightstreamer to run up under Eclipse. I keep getting

    Code:
    Error reading logging configuration file conf\lightstreamer_log_conf.xml:java.lang.NullPointerException
        at com.lightstreamer.init.c.a(c.java)
        at com.lightstreamer.a.e.d.a(d.java)
        at com.lightstreamer.f.b.a(b.java)
        at com.lightstreamer.f.b.a(b.java)
        at com.lightstreamer.f.a.a(a.java)
        at com.lightstreamer.LS.main(LS.java)
    Unable to load settings for logging system.
    Startup failed.
    The file is there and seems to work outside eclipse

    everything appears to be set correctly and LS runs just fine when run from the batch file in the Windows directory outside eclipse.

    Tearing my hair out ( Don't want to go back inside the office! )
    Last edited by nimbusgb; July 5th, 2019 at 10:01 AM.

  5. #25
    A re-install in a different directory and the problem has moved a little

    Code:
    05.Jul.19 16:31:44,027 <DEBUG> Monitoring system started05.Jul.19 16:31:44,027 <DEBUG> Initializing answering system...
    05.Jul.19 16:31:44,028 < INFO> SERVER pool size set by default at 1000.
    05.Jul.19 16:31:44,036 <DEBUG> Initializing SERVER thread pool; max size = 1000; initial size = 10
    05.Jul.19 16:31:44,087 < WARN> THE MONITORING DASHBOARD IS NOT PASSWORD PROTECTED. Remember to protect it in production! For more details, see PRODUCTION_SECURITY_NOTES.TXT.
    05.Jul.19 16:31:44,096 < INFO> Pump pool size set by default at 8.
    05.Jul.19 16:31:44,096 <DEBUG> Initializing PUMP thread pool; max size = 8; initial size = 8
    05.Jul.19 16:31:44,104 <DEBUG> Answering system started
    05.Jul.19 16:31:44,104 <DEBUG> Initializing MPN Module...
    05.Jul.19 16:31:44,107 <DEBUG> Found com.lightstreamer.database_lib_path as C:\GMSls/lib/mpn/hibernate/*;C:\GMSls/lib/lightstreamer.jarC:\GMSls
    05.Jul.19 16:31:44,107 <DEBUG> Found paths: C:\GMSls/lib/mpn/hibernate/*
    05.Jul.19 16:31:44,107 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\activation-1.1.1.jar
    05.Jul.19 16:31:44,107 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\antlr-2.7.7.jar
    05.Jul.19 16:31:44,107 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\c3p0-0.9.5.2.jar
    05.Jul.19 16:31:44,108 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\classmate-1.3.4.jar
    05.Jul.19 16:31:44,108 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\dom4j-1.6.1.jar
    05.Jul.19 16:31:44,108 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\geronimo-jta_1.1_spec-1.1.1.jar
    05.Jul.19 16:31:44,108 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\hibernate-c3p0-5.1.10.Final.jar
    05.Jul.19 16:31:44,108 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\hibernate-commons-annotations-5.0.1.Final.jar
    05.Jul.19 16:31:44,108 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\hibernate-core-5.1.10.Final.jar
    05.Jul.19 16:31:44,108 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\hibernate-jpa-2.1-api-1.0.0.Final.jar
    05.Jul.19 16:31:44,109 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\jandex-2.0.3.Final.jar
    05.Jul.19 16:31:44,109 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\javassist-3.23.1-GA.jar
    05.Jul.19 16:31:44,109 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\jaxb-api-2.3.0.jar
    05.Jul.19 16:31:44,109 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\jaxb-core-2.3.0.1.jar
    05.Jul.19 16:31:44,109 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\jaxb-impl-2.3.0.1.jar
    05.Jul.19 16:31:44,109 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\jboss-logging-3.3.0.Final.jar
    05.Jul.19 16:31:44,109 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\log4j-over-slf4j-1.7.25.jar
    05.Jul.19 16:31:44,110 <DEBUG> Found jar: C:\GMSls\lib\mpn\hibernate\mchange-commons-java-0.2.12.jar
    05.Jul.19 16:31:44,110 <DEBUG> Found path: C:\GMSls/lib/lightstreamer.jarC:\GMSls
    05.Jul.19 16:31:44,118 <ERROR> Can't find database management class.
    java.lang.ClassNotFoundException: com.lightstreamer.c.e.e
    	at java.net.URLClassLoader.findClass(Unknown Source)
    	at java.lang.ClassLoader.loadClass(Unknown Source)
    	at java.net.FactoryURLClassLoader.loadClass(Unknown Source)
    	at java.lang.ClassLoader.loadClass(Unknown Source)
    	at com.lightstreamer.init.c.a(c.java)
    	at com.lightstreamer.c.b.a.<init>(a.java)
    	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    	at java.lang.reflect.Constructor.newInstance(Unknown Source)
    	at com.lightstreamer.i.f.a(f.java)
    	at com.lightstreamer.i.f.a(f.java)
    	at com.lightstreamer.i.f.a(f.java)
    	at com.lightstreamer.c.m.a(m.java)
    	at com.lightstreamer.i.q.i(q.java)
    	at com.lightstreamer.i.q.<init>(q.java)
    	at com.lightstreamer.f.a.a(a.java)
    	at com.lightstreamer.LS.main(LS.java)
    05.Jul.19 16:31:44,119 <ERROR> Error in MPN Module initialization: Database management class not supplied.
    05.Jul.19 16:31:44,119 <FATAL> MPN Module initialization error.
    Ever get the feeling that you are in a portal from hell?

  6. #26
    It would appear that this lot does not play well with Eclipse EE edition. Switched to the plain java version and all my challenges went away.

  7. #27
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Hi, Thank you for the report.
    It seems as though that environment caused getClassLoader to return null for some classes belonging to Lightstreamer.
    BTW, have you managed to put the "ls-bootstrap.jar" library in the boot classloader? It is supposed to be in the system classloader.
    Anyway, we can put a workaround and prevent the exception, but we cannot ensure the correct loading of classes in this scenario.

 

 

Similar Threads

  1. How can I set the listener in the Data adapter?
    By Priyanka in forum Adapter APIs
    Replies: 6
    Last Post: May 3rd, 2016, 05:12 PM
  2. Replies: 1
    Last Post: April 17th, 2015, 10:59 AM
  3. how to create Adapter Set
    By msgiribabu in forum Adapter APIs
    Replies: 2
    Last Post: January 31st, 2011, 12:32 PM
  4. How to config eclipse to debug lightstreamer.
    By gengliangyu2008 in forum General
    Replies: 2
    Last Post: November 10th, 2010, 11:40 AM
  5. Replies: 1
    Last Post: May 21st, 2009, 10:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 05:38 PM.