Results 1 to 8 of 8
  1. #1
    Senior Member
    Join Date
    Aug 2014
    Posts
    71

    problem in command subscribe

    hello,
    today i noticed that when a form getting data from a command subscribe from LS, it get some rows (add command) then all rows is deleted one by one (delete command). but when i close the form and open it again that do resubscribe, it get the last one row from LS.
    what may cause the problem and is the LS may cache any data even it is received as deleted command from client?

  2. #2
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    543
    Hi engcoder,

    I confirm that the behavior experienced is not the one expected.
    If the client subscribe an Item in COMMAND mode, the snapshot is the shortest sequence of commands needed to build the current state of the table from scratch. So, in case of an empty table the client should not receive anything.

    In order to check what really happen, please could you replicate the case in a test environment after changing these log settings (in lightstreamer_log_conf.xml)?



    Regards,
    Giuseppe

  3. #3
    Senior Member
    Join Date
    Aug 2014
    Posts
    71
    this is the lightstreamer log file of today after i changed the log confg. as you showed
    http://www.mediafire.com/download/q1...+26-1-2016.rar

  4. #4
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    543
    Hi engcoder,

    I noticed that the log does not contain an isolated case, but multiple sessions with different subscriptions in COMMAND mode. I tried to verify some of these but I have not found the pattern complained.

    Please could you point me inside the log precisely to the issue? For example, specifying a specific time or a session id and an Item involved in the issue.

    Thank you,
    Giuseppe

  5. #5
    Senior Member
    Join Date
    Aug 2014
    Posts
    71
    hi,
    i am not understand what is the isolated case and its benefit?
    i don't remember the time of the problem but i guess it is not related to a time but it related to event that i noticed that when a form getting data from a command subscribe from LS, it get some rows (add command) then all rows is deleted one by one (delete command). but when i close the form and open it again that do resubscribe, it get the last one row from LS.

  6. #6
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    543
    Hi engcoder,

    By "isolated case" I mean:
    - start a Lightstreamer server (for example a test or development server that are already in use) with the log settings suggested;
    - connect with only a single client;
    - repeating the minimum activities client-side to reproduce the issue;
    - shut down the server.

    In this way, the resulting log will be more compact and easier to read, helping us to identify the problem.

    In any case, I have noticed that subscriptions for type COMMAND involving Items such these: pa11, pb11, pa2, ...
    Could you tell us which of these should we examine?

    Thank you,
    Giuseppe

  7. #7
    Senior Member
    Join Date
    Aug 2014
    Posts
    71
    hello,
    i already do the isolatiotion for only one client outside the server and repeat activities.
    you examine the subscribtions of items have the prefix pa and pb.

  8. #8
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    543
    Hi engcoder,

    I am sorry but I was not able to recognize the issue in the log.
    However, I can report that I have often found messages like these:

    26-Jan-16 16:02:55,272|DEBUG|LightstreamerLogger.subscriptio ns|ol.DataPool Notify Receiver|INCOMING DATA for pb11 on DataPool.DataPool --> ...
    26-Jan-16 16:02:55,272|WARN |LightstreamerLogger.preprocessor |ol.DataPool Notify Receiver|Unexpected UPDATE event for key 33-p1-8. Event propagated as an ADD command.


    This mean that when Lightstreamer server asks for the snapshot receives from your Adapter some UPDATE events. While, as snapshot events, only ADDs are expected.
    Could be that the adapter send some of this UPDATEs incorrectly?

    Regards,
    Giuseppe

 

 

Similar Threads

  1. Replies: 2
    Last Post: December 24th, 2010, 08:51 AM
  2. Client validation inside subscribe call
    By antiGuru in forum Adapter APIs
    Replies: 1
    Last Post: February 5th, 2010, 10:55 AM
  3. dynamically subscribe items
    By rd2008 in forum General
    Replies: 9
    Last Post: October 10th, 2008, 11:38 AM
  4. subscribe to items not using threads
    By nagakumaran in forum Adapter APIs
    Replies: 6
    Last Post: October 16th, 2007, 03:11 PM
  5. Data Adapter's subscribe() method not getting called
    By CitiMan in forum Adapter APIs
    Replies: 8
    Last Post: November 30th, 2006, 05:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 04:36 AM.