Page 1 of 3 123 LastLast
Results 1 to 10 of 29
  1. #1
    Senior Member
    Join Date
    Aug 2014
    Posts
    71

    Problem in loading Adapters

    hello,

    i have 3 adapters worked on LS version 5.2
    i decided to work on the new version 6 build and i make the changes in the adapters xml config. to be suitable to the new version

    but when i start the LS, it stopped at :
    < INFO> Loading Metadata Adapter DataPool
    < INFO> Connecting...
    < INFO> Waiting for a connection on port 6663...

    and not complete !!

    my adapter.xml is as follow:

    Code:
    <?xml version="1.0"?>
    
    
    <adapters_conf id="DataPool">
    
    
      <metadata_adapter_initialised_first>Y</metadata_adapter_initialised_first>
    
    
        <adapter_set_pool>
            <max_size>7</max_size>
            <max_free>0</max_free>
        </adapter_set_pool>
    
    
    
    
       <metadata_provider>
      <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
      <param name="request_reply_port">6663</param>
    </metadata_provider>
    	
     
        <data_provider name="DataPool">
            <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
      <param name="request_reply_port">6661</param>
      <param name="notify_port">6662</param>
        </data_provider>
    	
    
    
    
    
    <data_provider name="Intraday1">
    
    
     <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
            
     <param name="request_reply_port">5661</param>
    <param name="notify_port">5662</param>
    
    
        </data_provider>
    
    
    
    
    <data_provider name="Intraday2">
    
    
     <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
    
    
    <param name="request_reply_port">7661</param>
    <param name="notify_port">7662</param>
    
    
        </data_provider>
    
    
    </adapters_conf>
    Last edited by engcoder; April 16th, 2015 at 02:23 PM.

  2. #2
    Administrator
    Join Date
    Feb 2008
    Location
    Siracusa
    Posts
    152
    Hi engcoder,

    probably the issue is due to setting of parameter <metadata_adapter_initialised_first>.
    With Lightstreamer 6, the initialization order for Metadata Adapters and Data Adapters has been changed: by default the Metadata Adapter is initialized before any Data Adapter of the same Adapter Set and the brand new optional configuration parameter "metadata_adapter_initialised_first" has been introduced to initialise the Metadata Adapter in parallel with the Data Adapters.
    You can get more on this here:

    Maybe the TCP ports opening sequence of your remote adapters requires a different initialization order for the proxy adapters, so switch the value from "Y" o "N" and get back to us for any further assistance.

    By the way consider that a brand new online tool to simplify the migration process of main configuration files is under development. Such tool is expected in few weeks.

    Regards,
    Gianluca

  3. #3
    Senior Member
    Join Date
    Aug 2014
    Posts
    71
    thanks for reply,
    the adapters is loaded when i changed Y to N
    but the LS gives Exception after connecting to the ports :

    <ERROR> Exception caught while trying to initialize the Remote Servercom.lightstreamer.adapters.proxy.RemotingExc eption: Timeout while waiting for an
    answer to request 10000014ccb4c5f0a






  4. #4
    Administrator
    Join Date
    Feb 2008
    Location
    Siracusa
    Posts
    152
    Hi,

    which version of Remote Adapter SDK are you using for your remote servers?

    Thanks
    Gianluca

  5. #5
    Senior Member
    Join Date
    Aug 2014
    Posts
    71
    what is the SDK and where?
    i use the LS 6.0 Build

  6. #6
    Senior Member
    Join Date
    Aug 2014
    Posts
    71
    are you mean the "DotNetAdapter_N2.dll"? it is version 1.7
    and "log4net.dll" is 1.2

  7. #7
    Administrator
    Join Date
    Feb 2008
    Location
    Siracusa
    Posts
    152
    Yes,

    with Lightstreamer 6 you are strongly encouraged to upgrade your remote SDK for NET Adapter to version 1.9, as version 1.7 of Adapter Remote Infrastructure could lead to some compatibility issues with existing Remote Servers based on .NET Adapter. Please have a look at the compatibility notes.

    However, if you are not going to upgrade your remote servers with a newer version of SDK for NET Adapter, you should configure the new "init_remote" parameter to "false", in order to enforce compatibility with remote servers compliant with ARI version older than 1.5, as is in your case (last build of NET Adapter version 1.7 is compatible with ARI version 1.4.3).

    Please note that once you upgrade remote servers, you also MUST change the parameter value to "true".

    To recap, the following are new settings:

    Code:
    <?xml version="1.0"?>
    
    <adapters_conf id="DataPool">
      
      <metadata_adapter_initialised_first>Y</metadata_adapter_initialised_first>
    
      <adapter_set_pool>
        <max_size>7</max_size>
        <max_free>0</max_free>
      </adapter_set_pool>
    
      <metadata_provider>
        <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
        <classloader>log-enabled</classloader>
        <param name="request_reply_port">6663</param>
    
        <param name="init_remote">false</param>
    
      </metadata_provider>
      
      <data_provider name="DataPool">
        <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
        <classloader>log-enabled</classloader>
        <param name="request_reply_port">6661</param>
        <param name="notify_port">6662</param>
    
        <param name="init_remote">false</param>
    
      </data_provider>
      
      <data_provider name="Intraday1">
        <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
        <classloader>log-enabled</classloader>
        <param name="request_reply_port">5661</param>
        <param name="notify_port">5662</param>
    
        <param name="init_remote">false</param>
    
      </data_provider>
    
      <data_provider name="Intraday2">
        <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
        <classloader>log-enabled</classloader>
        <param name="request_reply_port">7661</param>
        <param name="notify_port">7662</param>
    
        <param name="init_remote">false</param>
    
      </data_provider>
    
    </adapters_conf>

    Regards,
    Gianluca

  8. #8
    Senior Member
    Join Date
    Aug 2014
    Posts
    71
    thanks,
    now the LS worked and listen for port 8080. but when the adapter then connects to the LS, it gives exception :
    An unhandled exception of type 'Lightstreamer.DotNet.Client.PushConnException' occurred in DotNetClient_N2.dll


    Additional information: The remote server returned an error: (500) Internal Server Error.


    this is the code for connecting:

    ConnectionInfo _cInfo = new ConnectionInfo();
    _cInfo.PushServerUrl = "http://localhost:8080";
    _cInfo.Adapter = "DataPool";


    LSClient client1 = new LSClient();
    client1.OpenConnection(_cInfo, new Tabee3ConnectionListener());


    is there any changes in that?

  9. #9
    Administrator
    Join Date
    Feb 2008
    Location
    Siracusa
    Posts
    152
    Hi,

    could you please try again after modifying the level of "LightstreamerLogger.connectionss" logger to "DEBUG" in lightstreamer_conf_log.xml? Once done, please send us the log for further investigations.

    Regards,
    Gianluca

  10. #10

 

 

Similar Threads

  1. Replies: 7
    Last Post: April 20th, 2015, 09:10 AM
  2. Replies: 3
    Last Post: March 4th, 2011, 11:35 PM
  3. How to let Data and Metadata Adapters comunicate
    By CitiMan in forum Adapter APIs
    Replies: 4
    Last Post: November 21st, 2008, 05:24 PM
  4. speed up initial loading
    By rd2008 in forum General
    Replies: 1
    Last Post: November 20th, 2008, 09:32 AM
  5. Accessing multiple adapters
    By Waddy in forum General
    Replies: 2
    Last Post: March 16th, 2007, 06:06 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 06:18 AM.