Results 1 to 10 of 29

Threaded View

  1. #1
    Senior Member
    Join Date
    Aug 2014
    Posts
    71

    Problem in loading Adapters

    hello,

    i have 3 adapters worked on LS version 5.2
    i decided to work on the new version 6 build and i make the changes in the adapters xml config. to be suitable to the new version

    but when i start the LS, it stopped at :
    < INFO> Loading Metadata Adapter DataPool
    < INFO> Connecting...
    < INFO> Waiting for a connection on port 6663...

    and not complete !!

    my adapter.xml is as follow:

    Code:
    <?xml version="1.0"?>
    
    
    <adapters_conf id="DataPool">
    
    
      <metadata_adapter_initialised_first>Y</metadata_adapter_initialised_first>
    
    
        <adapter_set_pool>
            <max_size>7</max_size>
            <max_free>0</max_free>
        </adapter_set_pool>
    
    
    
    
       <metadata_provider>
      <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
      <param name="request_reply_port">6663</param>
    </metadata_provider>
    	
     
        <data_provider name="DataPool">
            <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
      <param name="request_reply_port">6661</param>
      <param name="notify_port">6662</param>
        </data_provider>
    	
    
    
    
    
    <data_provider name="Intraday1">
    
    
     <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
            
     <param name="request_reply_port">5661</param>
    <param name="notify_port">5662</param>
    
    
        </data_provider>
    
    
    
    
    <data_provider name="Intraday2">
    
    
     <adapter_class>PROXY_FOR_REMOTE_ADAPTER</adapter_class>
      <classloader>log-enabled</classloader>
    
    
    <param name="request_reply_port">7661</param>
    <param name="notify_port">7662</param>
    
    
        </data_provider>
    
    
    </adapters_conf>
    Last edited by engcoder; April 16th, 2015 at 02:23 PM.

 

 

Similar Threads

  1. Replies: 7
    Last Post: April 20th, 2015, 09:10 AM
  2. Replies: 3
    Last Post: March 4th, 2011, 11:35 PM
  3. How to let Data and Metadata Adapters comunicate
    By CitiMan in forum Adapter APIs
    Replies: 4
    Last Post: November 21st, 2008, 05:24 PM
  4. speed up initial loading
    By rd2008 in forum General
    Replies: 1
    Last Post: November 20th, 2008, 09:32 AM
  5. Accessing multiple adapters
    By Waddy in forum General
    Replies: 2
    Last Post: March 16th, 2007, 06:06 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 09:13 PM.