Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2011

    Hello World -- Socket

    Hi All,

    I have followed the example written in the below link:

    what i did is,
    setup the server and adapters successfully then run the ls_sever and two telnet commands request/response window and notification window and opened the index.htm.

    i can see the telnet comands are connected to ls_Server but when finish loading index.htm nothing done.. no subscription.. and i cannot see the actual id that i should replace it with example to send message.. and when i trying to send message [WARN] will appear in the ls_Server.

    please if anyone can help me on this, i need to send message from the server and received by client to process it. and if anyone has worked successfully run the telnet commands via .net please send it to me.I cannot see the results of below posted paragraph after open the index.htm link nothing happens:
    "The “greetings” item has been subscribed too by the Client, with a schema comprised of the “message” and “timestamp” fields. The Server has then subscribed to the same item through our Remote Adapter (due to the fact that Lightstreamer Server v.3.x is based on a “Publish On-Demand” paradigm). This subscription will manifest itself as a request in the requets/response window, similar to the following:

    Thanks in advance,

  2. #2
    Join Date
    Jul 2006
    So, as a result of the index.html page being shown by the browser, you don't see the subscription request being written on your "request/response" telnet window.
    First, we should ascertain that the client has been able to open the streaming session on the Server.
    Please show us the Server log produced during your attempt.

    By the way, have you also tried the basic tutorial with success?

  3. #3
    Join Date
    Oct 2011
    Thanks Mr. DarioCrivelli,

    as you said the problem was in subscription and i went through the demos to create push page as they had created and works fine. but if you know any tutorial or example provide the telnets commnads using .net application as listed in perl because perl example not working with me but basic telnet works.

    Best Regards,

  4. #4
    Power Member
    Join Date
    Jul 2006
    Cesano Maderno, Italy

    we never wrote a perl example but something was in the comments of Alessandro's post here:
    Is that the example that does not work?

    Note that the ARI protocol is fully documented; You can find it in the DOCS-SDKs\sdk_adapter_remoting_infrastructure\doc folder in the Lightstreamer distribution


  5. #5
    I thought that adapter sets are sandboxed and independant from each other.????
    We are the leading the world in providing best dumps prep solutions. Our incredible offers for and gedare accessible at reasonable prices; our Florida National University is very rare in IT world.

  6. #6
    Join Date
    Feb 2012
    Hi Pyarsekaho,

    I confirm that each Adapter Set installed in a Lightstreamer server is independent from each other.
    Furthermore version 6.0 introduced separate ClassLoaders for loading the resources related with the various Adapter Sets.
    As a consequence, classes pertaining to different Adapter Sets can no longer see each other, though they can still share any classes defined in the "shared" folder. Please refer to changelog of version 6.0 for further details.

    Nevertheless this has major implications in case the Java In-Process Adapters library is in use.
    In the case of Remote Adapters, as discussed in this thread, the implications are limited because the Adapter are implemented with technology freely chose by the developer, and the communication with the server simply rely on 3 TCP/IP connections and a well-defined protocol.




Similar Threads

  1. Replies: 5
    Last Post: April 30th, 2010, 11:03 AM
  2. Hello World Remote Socket Adapter
    By kclerc in forum Adapter SDKs
    Replies: 7
    Last Post: April 12th, 2010, 12:40 PM
  3. Replies: 9
    Last Post: June 3rd, 2009, 10:56 AM
  4. Hello World Error
    By jaguarg in forum Adapter SDKs
    Replies: 2
    Last Post: November 5th, 2008, 09:38 PM
  5. Replies: 0
    Last Post: January 10th, 2007, 05:03 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
All times are GMT +1. The time now is 01:45 AM.