Results 1 to 2 of 2
  1. #1

    Null values on Item update

    I have subscribed to an item on our server and when it is updated the client receives an UpdateInfo whos fields are all null. Any idea what may cause this? MERGE, DISTINCT, and RAW all return this result.I have subscribed to an item on our server and when it is updated the client receives an UpdateInfo whos fields are all null. Any idea what may cause this? MERGE, DISTINCT, and RAW all return this result.

  2. #2
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    538
    Hi atif,

    First, please consider that: if you declare you have a snapshot in the isSnapshotAvailable method and then you send the first update with the snapshot flag set to false, this will cause the server to consider the snapshot to be made of empty values and thus it will send nulls. After that it sends the first update of your adapter.
    Can you please check if this is your case?

    Otherwise, I think that the best way to investigate the issue should be increasing the log level. Please set these two logger (in lightstreamer_log_conf.xml) to DEBUG level



    and post here a snippet of the lightstreamer.log file with the involved susbscription request.

    Regards,
    Giuseppe

 

 

Similar Threads

  1. Null Values in OnUpdate
    By New Soft in forum Client APIs
    Replies: 7
    Last Post: September 18th, 2014, 09:49 AM
  2. Error handling for: [Unexpected update for item]
    By tony99nyr in forum Adapter APIs
    Replies: 3
    Last Post: April 7th, 2014, 09:29 AM
  3. Replies: 2
    Last Post: March 29th, 2013, 02:59 AM
  4. Replies: 1
    Last Post: April 17th, 2012, 09:19 AM
  5. Strange Error on item update
    By mnenchev in forum Client APIs
    Replies: 10
    Last Post: March 19th, 2010, 08:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 01:34 AM.