Results 1 to 4 of 4
  1. #1
    Power Member
    Join Date
    Nov 2012
    Posts
    182

    Exception in thread "main" java.lang.NoClassDefFoundError: ch.qos.logback.core.Append

    Any idea what might cause this fatal error on start-up?

    Is it a configuration issue or an issue with the Java installation. In this instance, they are attempting to use Java 6 pending a Java 7 install.

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Probably it is the whole logback-core jar that is (unexpectedly) not reachable.
    Which version of the Server are you using?
    (in fact, the position of the jars in our deployment has recently changed).

    On the other hand, the version of Java should not be significant in this case.

  3. #3
    Power Member
    Join Date
    Nov 2012
    Posts
    182
    Well in the meantime they have upgraded to Java 7 (it is an IBMi Power Server) and the problem has gone away

  4. #4
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Ok, sorry; we weren't aware of possible issues involving the logback library and special environments.

 

 

Similar Threads

  1. Replies: 1
    Last Post: April 18th, 2014, 09:59 AM
  2. Register with Command only to "ADD" and "REMOVE"
    By lidanh in forum Client APIs
    Replies: 4
    Last Post: August 6th, 2013, 06:27 PM
  3. Replies: 3
    Last Post: February 19th, 2010, 12:14 AM
  4. Replies: 10
    Last Post: July 15th, 2009, 11:02 AM
  5. com.lightstreamer.i.jc cannot be cast to java.lang
    By ddhanis in forum Adapter APIs
    Replies: 4
    Last Post: March 4th, 2009, 09:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 06:34 PM.