Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Nov 2007
    Location
    London
    Posts
    18

    Sophos Anti-virus

    Hi,

    We recently updated Sophos Anti-Virus across our network to version 7.6.4. Now, whenever we connect to a Lightstreamer server (incuding your StockListDemo) using the html client, we can only run in Smart Polling mode.

    Disabling 'On Access Scanning' allows Streaming mode to be established, however doing this is not an option.

    Do you know of any workarounds for this?

    Many thanks,

    Richard

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan, Italy
    Posts
    518
    Hi Richard,

    Some anti-virus software is known to block any streaming HTML connection. It seems that this new version of Sophos is doing that. In other words, this software wants to download the full HTTP response before making it available to the browser. Obviously, this behavior is not compatible with a streaming paradigm.

    That's why Lightstreamer has the "stream-sense" feature, which automatically switches to smart polling whenever something in the middle block streaming. Consider that smart polling is highly efficient in Lightstreamer and in many cases the final user cannot distinguish it from real streaming.

    You could also try to use HTTPS instead of HTTP. In many cases, when facing HTTPS, the anti-virus accepts to forward the response in real-time.

  3. #3
    Member
    Join Date
    Nov 2007
    Location
    London
    Posts
    18
    Thanks Alessandro,

    To update, it seems like this is only an issue with IE. This version of Sophos installs an add-on, Sophos Web Content scanner, in IE. By turning this off (as a test) we were able to get a streaming connection again.

    We're using SSL, but given that Smart Polling seems to work well we've got some time to work out different ways of configuring Sophos.

    An alternative workaround is to use IE8's In-Private mode - this appears to disable add-ons in case they might record history data. The Sophos plugin doesn't run in this mode :-)

    Cheers,

    Richard

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 08:52 AM.