Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Mar 2008
    Location
    a
    Posts
    1

    Question On addTable() receveiving updates from previous group

    Hi lightstreamer team !

    We are using DynaMetapushTable for receiving updates for around 500 Stocks in COMMAND mode where entries may be added/updated.

    After we subscribe to another group of stocks in the same table before receiving all 500 stocks from previous group, the remainig stocks from group1 gets mixed with group2.

    I've tried to clear all data by setting:
    table.setClearOnRemove(true);
    table.setClearOnAdd(true);


    and also before subscribing to another group I've also removed previous table:
    page.removeTable(id);

    I've also tried removing visual effects, but there is no change.

    On my page I have a select box witch lets users subscribe to another group of stocks in COMMAND mode, and if the user changes a group of stocks before receiving all stocks from previous group, user receives a mix of stocks from previous group.
    The only solution I see now is to wait for all stocks to get loaded witch takes about 30 secs and then let user subscribe to another group.

    I'm not sure how to fix this problem.

    Any help is very appreciated!

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan, Italy
    Posts
    517
    Hi Jakov

    We can't replicate the case. After calling
    table.setClearOnRemove(true);
    page.removeTable(id);/
    the table should disappear and trailing updates should be ignored.

    If we understand well, the problem happens to you when you call those lines while the previous table is still loading. We also tried simulating this case, but we didn't notice any update from the previous table mixed with updates from the second one.

    We need more details on your case.

    Are you using Web Client Library version 4.3?

    If you, for testing, only issue
    table.setClearOnRemove(true);
    page.removeTable(id);/
    without adding the new table, can you see the table complete loading?

    Does the table loading take 30 seconds because of bandwidth restrictions? Or because of CPU overload on the client? Or because of slow data generation by the Data Adapter?

    Can you exclude any issue in the Data Adapter, perhaps mixing updates for different items?

  3. #3
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    After further tests we could replicate the case
    and recongnize it as a Web Client Library bug.
    Trailing updates pertaining to the previous association for the screen table are not filtered out correctly. This may affect any kind of screen table and subscription mode.
    We'll make a patch available as soon as possible.

  4. #4
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    Hello all,

    a patch for the problem described in this thread is available.

    If you are using the Lightstreamer Web Client v.4.3 build 1346 and think you are in the situation described below, you may want to apply the provided patch:

    On the Master Push-Page, if you call addTable() more times while using the same "id" parameter, there exist cases where the last updates pertaining to the previous subscription life are delivered as part of the new life. An example of this is if you define a screen table through your HTML cells, bind it to a Lightstreamer table, then remove the Lightstreamer table and add a new one in order to chnage the group name. If this is done in rapid sequence, the latest updates pertaining to the old group could be displayed after the new group has been subscribed to.

    If you find yourself in this kind of scenario and you are using Lightstreamer Web Client v.4.3 build 1346 (previous version are not affected by this issue), please contact support@lightstreamer.com to get the patch.

 

 

Similar Threads

  1. Using tomcat as the web server - no data updates
    By bhathiya in forum Client APIs
    Replies: 2
    Last Post: April 11th, 2011, 09:38 AM
  2. Previous Data Lost
    By peaks2006@gmail.com in forum Client APIs
    Replies: 1
    Last Post: October 6th, 2010, 10:18 AM
  3. Replies: 3
    Last Post: January 21st, 2010, 01:25 PM
  4. IG Group's cool applications
    By Alessandro in forum General
    Replies: 6
    Last Post: July 1st, 2008, 03:26 PM
  5. Adding/Removing item in subscribed group
    By rsouissi in forum Adapter APIs
    Replies: 4
    Last Post: January 10th, 2007, 07:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 09:25 PM.