Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    Sep 2008
    Location
    rmd
    Posts
    30

    CreateEngine - path - issues in chrome

    lsPage.createEngine("TutorialDemo", "LS/");

    this works fine in firefox3. but doesn't work in chrome. it says that unable to find the engine - bind

    (demo application is working fine on chrome. this happens for my application only)

    what is actually meant by path in createEngine?

    i'm using all the lightstreamer related javascript related stuffs in a separate js. (not inlined) it loads both lspushpage.js and commons.js correctly. then why cant it find this path?

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan, Italy
    Posts
    517
    The createEngine function specifies, as the second parameter, the base URL of the Lightstreamer Web Client Library resources (i.e. the URL of the directory containing the Library resources), in absolute or relative form.

    Sicne you put the createEngine call in an external JS, I suspect Chrome is interpreting your relative path in a different way than Firefox. You could try with an absolute path.

  3. #3
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    We have tried to replicate the issue, but haven't found any difference for Chrome.
    In our test, we simply included the js file from a <script> block.
    Please let us know if using an absolute path in "createEngine" causes any change.

  4. #4
    Senior Member
    Join Date
    Sep 2008
    Location
    rmd
    Posts
    30
    i tried it. still no change. it cant find it.

    (I tried saving ls files in wamp server and giving entire path too)

  5. #5
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    There are various possible reasons for not getting the engine.
    For instance, the engine page may be loaded correctly, but then may not be accessible because of a document.domain problem.
    May you please check if the request for the "lsengine.html" page hits your web server?
    Can you see the demos on Lightstreamer website correctly on Chrome?

  6. #6
    Senior Member
    Join Date
    Sep 2008
    Location
    rmd
    Posts
    30
    Can you see the demos on Lightstreamer website correctly on Chrome?
    yes they are working.

    May you please check if the request for the "lsengine.html" page hits your web server?
    I'l let you know
    (FYI : i'm using velocity)

  7. #7
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    I have realized that you started from the tutorial demo.
    Note that the tutorial demo is based on Lightstreamer Server itself as the Web Server. If you now use an external Web Server, then the domain setting becomes important and has to be set properly.
    An improper setting of the domain may also lead to browser-dependent issues.
    Assuming you are using LS 3.4.8 (in the current 3.5 version the tutorial has been replaced) you can find instructions about the full deployment associated to the demos in DOCS-SDKs/sdk_client_web/examples. See StockListDemo/README.TXT, for instance.

    Note: in LS 3.5 the same instructions are reached in a different way and are in
    pages\demos\HOW_TO_DEPLOY_ON_YOUR_WEB_SERVER.TXT

 

 

Similar Threads

  1. Anchor targetting in push page in Firefox, Chrome
    By tsezuu in forum Client APIs
    Replies: 2
    Last Post: November 24th, 2011, 04:09 AM
  2. Replies: 1
    Last Post: November 9th, 2011, 10:02 AM
  3. Chrome 6 --> TLS Cipher Suites
    By Alessandro in forum Client APIs
    Replies: 0
    Last Post: September 13th, 2010, 06:15 PM
  4. createEngine should be in the BODY ??
    By mohamida in forum Client APIs
    Replies: 10
    Last Post: August 18th, 2010, 01:50 PM
  5. unable to find engine-chrome browser
    By georgeeapen in forum Client APIs
    Replies: 1
    Last Post: May 25th, 2009, 10:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 01:12 AM.