Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Jul 2008
    Location
    Cresta
    Posts
    2

    Some help with ARI

    Hi Guys,
    I'm afraid I'n missing something with the ARI interpretation.
    I've got my 3 sockets created and nothing happens. This is of course fine, because I only expect action when a web client connects. When this happens I indeed get following to the MetaData Port:

    10000011b3175d082|NUS|S|#|S|#
    I Reply :
    10000011b3175d082|NUS|D|40|B|0

    I then get the next item as follows:

    20000011b3175d082|NNS|S|#|S|S2e792cbcc52f6b44T3923 139
    to which I reply
    20000011b3175d082|NNS|V

    Then nothing happens - I don't get schema requests or subscribes on any of the other 2 ports for the Data Adapter.

    After a while, I get
    30000011b3179128f|NSC|S|Sad8650536a5f014aT4251398

    My index.html looks as follows:

    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <title>Test</title>
    <script src="ls/lscommons.js"></script>
    <script src="ls/lspushpage.js"></script>
    <script>

    function startEngine(eng) {
    eng.connection.setLSHost(null);
    eng.connection.setLSPort(null);
    eng.connection.setAdapterName("PROXY_SOCKET");
    eng.changeStatus("STREAMING");
    }


    var lsPage = new PushPage();
    lsPage.context.setDomain(null);
    lsPage.onEngineCreation = startEngine;
    lsPage.bind();

    </script>
    </head>

    <body>
    This is some stuff!!<br>
    <table border="1">
    <tr><td>
    <div source="lightstreamer" table="list" item="group1" field="item1">-</div>
    </td></tr>
    </table>


    <script>
    lsPage.createEngine("Test", "ls/");
    var group = ['group1'];
    var schema = ['item1'];
    var xTable = new OverWriteTable(group,schema,"MERGE");
    xTable.setSnapshotRequired(true);
    xTable.setRequestedMaxFrequency(1.0);
    lsPage.addTable(xTable,"list");
    </script>

    </body>
    </html>

    Can anyone tell me what I am doing wrong here ?

  2. #2
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    hi,

    maybe the problem is that the server does not receive the subscription because of a typo in your code:


    should be


    let me know if that solved your problem.

  3. #3
    Member
    Join Date
    Jul 2008
    Location
    Cresta
    Posts
    2

    Thanks!

    Thanks, that was it! Now I just have to figure out what the difference between groups, schemas and items are And look for a perl adapter integration.
    Thanks for the help.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 02:01 AM.