Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Mar 2008
    Location
    jersey city
    Posts
    1

    Client error - Unable to find the Engine

    Hi,

    I get Unable to bind the page error while I try to connect to remote lightstreamer server.
    However, if I set domain as "null" then it tries to connect but it gives me security error in the page.

    Following is the code:

    <html>

    <head>
    <script type='text/javascript' src="ls/lscommons.js"></script>
    <script type='text/javascript' src="ls/lspushpage.js"></script>

    </head>

    <body>

    <script>
    /////////////////////////////////PushPage Configuration

    var lsPage = new PushPage();
    // lsPage.context.setDebugAlertsOnClientError(false);
    lsPage.context.setDomain("mycompany.com");
    //lsPage.context.setDomain(null);
    lsPage.onEngineCreation = startEngine;
    lsPage.bind();
    lsPage.createEngine("SLEngine", "ls/");

    function startEngine(eng) {
    eng.context.setDebugAlertsOnClientError(true);
    eng.policy.setMaxBandwidth(30);
    eng.policy.setIdleTimeout(30000);
    eng.policy.setPollingInterval(1000);
    eng.connection.setLSHost("server1.is.mycompany.com ");
    eng.connection.setLSPort(8085);
    eng.connection.setAdapterName("STOCKJMS");
    eng.changeStatus("STREAMING");
    }

    </script>
    </body>

    </html>

    Any help is appreciated.

    Thanks in advance!

  2. #2
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    Hello,

    assuming that your Lightstreamer is deployed on server1.is.mycompany.com on port 8085, the code seems correct.

    Where is deployed your page?
    How do you acces your page (what is the address in the browser's address bar)? It should be something like webserver.mycompany.com

    Please take a look to these pages: http://www.google.it/search?q=%22una...htstreamer.com

 

 

Similar Threads

  1. unable to find engine-chrome browser
    By georgeeapen in forum Client APIs
    Replies: 1
    Last Post: May 25th, 2009, 10:21 AM
  2. Unable to find Engine
    By ap7256 in forum Client APIs
    Replies: 15
    Last Post: January 14th, 2009, 10:36 AM
  3. ER bind Unable to find the Engine
    By eduramires in forum Client APIs
    Replies: 3
    Last Post: February 4th, 2008, 10:14 AM
  4. ER bind Unable to find the Engine
    By eduramires in forum General
    Replies: 1
    Last Post: January 29th, 2008, 06:03 PM
  5. Unable to find the Engine
    By RichP1 in forum Client APIs
    Replies: 6
    Last Post: December 18th, 2007, 02:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 11:58 AM.