Results 1 to 3 of 3
  1. #1

    exception from OpenConnection

    Hi,

    I am trying to connect to server, but in the following lines,
    LSClient c = new LSClient();
    c.OpenConnection(connInfo, new RzConnectionListener() );

    I got the exception, error as:

    An unhandled exception of type 'Lightstreamer.DotNet.Client.PushUserException' occurred in DotNetClient_N2.dll

    Additional information: Requested Adapter Set not available

    RzConnectionListener is my class from IConnectionListener, as the following.

    public class RzConnectionListener : IConnectionListener
    {
    private long bytes = 0;

    public RzConnectionListener() {}

    public void OnConnectionEstablished() {
    Console.WriteLine("connection established");
    }

    public void OnSessionStarted(bool isPolling) {
    if (isPolling) {
    Console.WriteLine("smart polling session started");
    } else {
    Console.WriteLine("streaming session started");
    }
    }
    ....


    }


    Can you please help?


    Thanks

  2. #2
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    538
    Hi emmajyu,

    You should check in the lines of code that instantiate and then configure the connInfo object, something similar to this
    Code:
                ConnectionInfo connInfo= new ConnectionInfo();
                connInfo.PushServerUrl= "http://" + pushServerHost + ":" + pushServerPort;
                connInfo.Adapter= "DEMO";
    Please look for the server to which you are connecting, for example if you're hitting your local instance of Lightstreamer. And then check whether the server to which you are connected has succesfully deployed the Adapter Set concerned.

    In fact, the exception "Requested Adapter Set not available" refers precisely to the fact that the Adapter Set configured by connInfo.Adapter = "XXXX" is not deployed on the server to which you are connected.

    If you are connecting to a local instance of Lighstreamer a way to check which are the Adpaters successfully loaded is to look in the server log file where the "init" logger lists the loaded Adapters and reports any problems.

    Please note that I have removed the thread in the ".Net Adapter API" forum considering it identical to this one.

  3. #3
    Quote Originally Posted by giuseppe.corti View Post
    Hi emmajyu,

    You should check in the lines of code that instantiate and then configure the connInfo object, something similar to this
    Code:
                ConnectionInfo connInfo= new ConnectionInfo();
                connInfo.PushServerUrl= "http://" + pushServerHost + ":" + pushServerPort;
                connInfo.Adapter= "DEMO";
    Please look for the server to which you are connecting, for example if you're hitting your local instance of Lightstreamer. And then check whether the server to which you are connected has succesfully deployed the Adapter Set concerned.

    In fact, the exception "Requested Adapter Set not available" refers precisely to the fact that the Adapter Set configured by connInfo.Adapter = "XXXX" is not deployed on the server to which you are connected.

    If you are connecting to a local instance of Lighstreamer a way to check which are the Adpaters successfully loaded is to look in the server log file where the "init" logger lists the loaded Adapters and reports any problems.

    Please note that I have removed the thread in the ".Net Adapter API" forum considering it identical to this one.
    thanks a lot for your help, yeah, I corrected the Adapter setting, now I get connected.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 05:34 PM.