Results 1 to 5 of 5
  1. #1

    Question The connection status shows CONNECTING

    Hi there,

    I am applying 5.1.1 Colosseo on Flex Mobile Project. I managed to set up the connection and subscribe to the table in the emulator and the status is showing 'STREAMING'. BUT, the status turns into 'CONNECTING' when it tries to connect for the third time. The following is my status:

    Code:
    //first time
    DISCONNECTED => CONNECTING
    CONNECTING => STREAMING
    
    //second time
    DISCONNECTED => CONNECTING
    CONNECTING => STREAMING
    
    //third time
    DISCONNECTED => CONNECTING
    ........
    Please help.
    Last edited by Victor Yew; May 21st, 2013 at 10:22 AM.

  2. #2
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    538
    Hi Victor,

    We would need some more details to go deeper into the issue.
    Can you define the scenario of your test? The three attempts you mention are performed one after another, maybe against a connection drop, or you start three parallel connections running simultaneously to the same server?

    However, if it is possible for you, please attach a snippet of Lightstreamer server log with the isolated case of the issue.

  3. #3
    Quote Originally Posted by giuseppe.corti View Post
    Hi Victor,

    We would need some more details to go deeper into the issue.
    Can you define the scenario of your test? The three attempts you mention are performed one after another, maybe against a connection drop, or you start three parallel connections running simultaneously to the same server?
    Ok. Here's the scenario. I build this application where it has a muti-tab panel in flex. The first panel connects to the lightstreamer server and manage to subscribe to the table. Then, I navigate to the second panel which loads an empty page and I navigate back to the first panel which again connects to the lightstreamer server without error. THEN, I repeat the process and this time it fails to connect to the server with the connection status showing 'CONNECTING'. It stays the same for every attempt afterwards.

    Does that mean I have to close the connection to the lightstreamer server every time I leave the first panel before I make a new connection in the second attempt?

    (Please note that the test is performed under stable internet connection and I can reproduce the error every time I repeat the test.)

  4. #4
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    538
    Hi Victor,

    You've probably reached the limit of connection pool (to the same host) that the environment of your client allow.
    As a general rule, if in the second attempt you create a new object, then yes, you have to close the connection on the previous one in order to avoid to burst the connection pool.
    Alternatively, you can arrange your code to reuse the same object each time.

  5. #5
    Hmm..I see. Thank you for the information, Corti.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 06:25 PM.