Results 1 to 3 of 3
  1. #1

    Using LS5.1.1 server with the old HTML client library version 5

    Hi,

    I've read the documentation but I'd like to still have a confirmation: is running a webapp built with the old "html" library (version 5, bundled with LS 4) over LS server version5 supported?

    We did some testing and everything looks fine, just a confirmation really.

    Thanks
    Regards
    Gabriele

  2. #2
    Administrator
    Join Date
    Feb 2012
    Location
    Milano
    Posts
    538
    Hi Gabriele,

    Yes, I confirm you that a client built with the HTML library version 5 will work fine with the new Lightstreamer server 5.x Colosseo. Indeed, as a rule of thumb, newer Lightstreamer servers usually support older clients. Viceversa newer clients are usually not compatible with older servers.

    However, the new JavaScript Client Library 6.0 is much easier to use, much faster, and has fully support of WebSocket protocol. So in order to get all this benefits we highly recommend upgrading to the latest version of the JavaScript client lib too.
    Please refer here for a tutorial on how to Upgrade to JavaScript Client Library 6.

  3. #3
    Yes, thank you. We're going to migrate to JS Client version 6 eventually, just not now.

    Thank you!
    Gabriele

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 07:53 AM.