Results 1 to 4 of 4

Thread: DotNet Adapter

  1. #1
    Member
    Join Date
    Aug 2007
    Location
    HaNoi
    Posts
    2

    DotNet Adapter

    Hi All ,
    I've one problem when i change Java Adapter to DotNet Adapter but when i browse StockListDemo on my browser then it didn't working . I copied all file into Folder \DotNetStockListDemo\Deployment\Deployment_LS\Stoc kList_sockets to Folder Lightstreamer\adapters\StockList . Then i run the DotNetServers.bat script in Folder DotNetStockListDemo\Deployment\Deployment_DotNet_S erver . But when i open DotNetServer.log file then it shows : Connection failed, retrying in 10 seconds... . I installed Framework 1.0 and 2.0 in my computer , i open port 6661,6662,6663 , i stopped windows firewall but it isn't working . Anyone can help me ?????

    Thanks for your attention

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Hi,
    which is the state of the Server when the Remote Server is logging "retrying"?
    The Server should write "Connecting..." and at least one of the involved ports should
    be shown by "netstat -a".
    See also this case.

    Dario

  3. #3
    Member
    Join Date
    Aug 2007
    Location
    HaNoi
    Posts
    2
    Thank Dario ,
    I read log file , it write : "2007-11-03 12:05:53,638 [3304] INFO Lightstreamer.DotNet.Server.NetworkedServerStarter [(null)] - Connecting... "
    "2007-11-03 12:05:53,794 [1064] WARN Lightstreamer.DotNet.Server.NetworkedServerStarter [(null)] - Connection failed, retrying in 10 seconds..." . And i used command netstat - a then it show : "TCP sw-19:2724 sw-19.abcde.com.vn:6663 SYN_SENT" or "TCP sw-19:2828 sw-19.abcde.com.vn:6661 SYN_SENT"
    I dont understand why it not working

  4. #4
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Hi

    It is quite unusual that a connection is in a SYN_SENT state.
    Is it possible that a local firewall is blocking packets back from Lightstreamer Server to the Remote Server?
    Can you also see the 6663 port as open for listening? (I assume that you are running both Lightstreamer Server and the Remote Server on the same machine).
    What can you see on Lightstreamer Server log? You should find it as logs\Lightstreamer.log

    Dario

 

 

Similar Threads

  1. dotnet demo Portfolio-Basic not work fine
    By lisicnu in forum Adapter APIs
    Replies: 3
    Last Post: December 8th, 2011, 03:41 AM
  2. Replies: 18
    Last Post: March 19th, 2008, 11:00 AM
  3. Unable to create New DotNET Adapter
    By shobha in forum Adapter APIs
    Replies: 4
    Last Post: August 13th, 2007, 02:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 08:32 AM.