Results 1 to 2 of 2
  1. #1

    License not valid for this Client version lightstreamer

    when i access a remote ls server by JavaScript for a test, it shows " License not valid for this Client version lightstreamer".
    the code snippet just like below:

    ...
    pushPage.context.setDomain("foo.com");
    ...
    lsEngine.context.setDebugAlertsOnClientError(true) ;
    lsEngine.connection.setLSHost("xxx.foo.com");
    lsEngine.connection.setLSPort(8080);
    lsEngine.connection.setUserName("user");
    lsEngine.connection.setPassword("password");
    lsEngine.connection.setAdapterName("MobileStreamin g");
    lsEngine.changeStatus("STREAMING");
    ...

    anyone can gimme some advice, thanks a lot.

  2. #2
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    That message means that the client in use is newer than the license installed on the server.
    To use that client with that server, assuming them are compatible, you need to change the server license.
    To check the compatibility you should check the compatibility note available in the client SDK.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 11:18 PM.