Results 1 to 6 of 6
  1. #1

    Lightstreamer Websocket Timout Problem

    Hi,

    anyone have any idea regarding the problem show in the pictures attached with this post. I guess there is something with lightstreamer conf file to change the timeout but can anyone specify the exact reason and if possible the solution. Thanks.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	lightstreamer_websocket_problem.png 
Views:	160 
Size:	37.0 KB 
ID:	104   Click image for larger version. 

Name:	lightstreamer_websocket_problem1.png 
Views:	161 
Size:	43.3 KB 
ID:	105  

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    973
    You seem to be concerned by the "timeout.11.0" text you found in the client HTTP request, but that should be considered as a detail of the internal client-server communication. It is not the signal of a problem in itself. Actually, it is just a notification with a debugging/diagnostic purpose.
    Please clarify if you see any malfunctioning on the page.

    Is the final disconnection reported in your screenshot also part of your inquiry?
    I suppose it isn't and that it just reports your final shutdown of the Server after the test.
    May you please confirm?

  3. #3
    Hi Dario,

    Yes, i'm concern about connection interruption. Do you need more details about the problem?

  4. #4
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    973
    Yes; please.
    As said, the screenshot shown could be replicated by simply shutting down the Server manually.
    If this was not the case, please provide us with a Server log snippet that includes the whole life of the involved session (or session creation attempt).
    If possible, try to replicate the issue after configuring the "LightstreamerLogger.connections" logger at DEBUG level;
    then provide the new corresponding client-side screenshot as well.

  5. #5
    I still could not reproduce the problem but got new problem from a client. check the screen shot and lightstreamer logs in the log file. Do you have any idea? Try to check the text in the image stated "Please specify at least one cell" which is from lightstreamer.js, then check the logs. Thanks.

    Quote Originally Posted by DarioCrivelli View Post
    Yes; please.
    As said, the screenshot shown could be replicated by simply shutting down the Server manually.
    If this was not the case, please provide us with a Server log snippet that includes the whole life of the involved session (or session creation attempt).
    If possible, try to replicate the issue after configuring the "LightstreamerLogger.connections" logger at DEBUG level;
    then provide the new corresponding client-side screenshot as well.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	myfavouritebeta_exception_cannot_subscribe_to_lightstreamer_server.jpg 
Views:	137 
Size:	51.3 KB 
ID:	106  
    Attached Files Attached Files
    Last edited by shabbirh; November 6th, 2012 at 11:34 AM.

  6. #6
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    Hi Shabbirh,

    Actually the subscription was successfull; what went wrong is the initialization of your Grid (either DynaGrid or StaticGrid depending on what you're using).
    Please double check your html and be sure that when you create your grid instance the required html is in place. (Alternatively you can set the second parameter of the Grid constructor to false and call parseHtml on the instance once the html is in place)

    If you think your html should already be ready then it is probably not correctly configured. You can refer to the JSDoc (StaticGrid / DynaGrid) to the examples or to the developer guide to verify how to prepare your html. If still in doubt post the html related to your grid(s) here.


    As a final note, please do not overload a single forum thread with multiple issues.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 04:13 PM.