Results 1 to 10 of 17

Hybrid View

  1. #1
    Member
    Join Date
    May 2007
    Location
    woodside
    Posts
    1

    Installing LS as a service in Windows 2003 [UPDATED: see last post in thread]

    Hi,

    I've just installed LS on a Windows 2003 server. LS works fine when launched as an application, but fails (LS webserver can't be found) when installed as a service (using the batch file provided) even when I have correctly configured wrapper.conf. I also don't get any errors in the logs. What could I be doing wrong?

    Thank you.

    Patrick

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    Hi Patrick

    Consider that the provided installation script does not also start the Server.
    It does not even install it for an automatical start after reboot
    (this last feature can be changed through the "wrapper.ntservice.starttype" property).

    Did you try to start it manually from Windows "services" list?
    In case you did, then may you please attach (or send to support@lightstreamer.com) the wrapper.log and Lightstreamer.log files produced?

    Dario

  3. #3
    Member
    Join Date
    Apr 2008
    Location
    n/a
    Posts
    1
    Was this ever resolved? I am too interested in managing Lightstreamer on Windows via a Windows service.

    Chris

  4. #4
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    975
    It seemed to be just a misunderstanding.
    The "Install_LS_as_Service-NT.bat" adds the Server to the available services, ready to be started through the windows services manager (%SystemRoot%\system32\services.msc /s on my PC).
    "peintre" presumably expected that "Install_LS_as_Service-NT.bat" would also run the Server.
    So, I think that there's nothing to be resolved. Are you encountering any issues?

  5. #5
    Member
    Join Date
    Sep 2009
    Location
    Mississauga
    Posts
    1

    Running LS as a Windows Service on Server 2008 64bit

    I know the wrapper.exe (the Community version included at least) doesn't run 64bit Windows so I should use the SC.exe utility.

    I can't quite figure the command out...Has anybody else done this successfully?

  6. #6
    Administrator
    Join Date
    Jul 2006
    Location
    Milan, Italy
    Posts
    517
    Actually, SC.EXE requires to create a special executable with the right hooks, which wraps the batch file. So it could not be the most viable solution.

    There exist some possible alternatives (one of which we will probably choose for a future release of Lightstreamer after some testing):

    + Instead of Java Service Wrapper, use YAJSW (http://yajsw.sourceforge.net/).

    + Instead of Java Service Wrapper, use Java Service Launcher (http://jslwin.sourceforge.net/).

    + Install the batch file as a service through the Windows Resource Toolkit (http://support.microsoft.com/kb/137890).

    + Upgrade to the paid version of Java Service Wrapper (http://wrapper.tanukisoftware.org/do...tLicenses.jsp).

 

 

Similar Threads

  1. Upgraded to LS 4 and many POST bind_session.txt
    By Adrian Parker in forum Client APIs
    Replies: 2
    Last Post: November 21st, 2011, 04:03 PM
  2. Installing problems
    By magnum_rg in forum General
    Replies: 5
    Last Post: August 9th, 2011, 06:52 PM
  3. Replies: 3
    Last Post: June 8th, 2011, 12:42 PM
  4. How to Get all updated fields in one attempt?
    By indrajit in forum Client APIs
    Replies: 3
    Last Post: March 3rd, 2008, 09:59 AM
  5. Installing LS on Apache?
    By rufnex in forum General
    Replies: 1
    Last Post: August 22nd, 2007, 04:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 08:55 AM.