Results 1 to 4 of 4
  1. #1

    Error on seekEngine, LightStreamer object not created

    Hi,

    I am creating a web-app on the lines of StockList Demo Frames example.
    I have a main page which has two frames.
    One of the frames has the engine_creation logic and the other the actual application logic with various links.

    The issue that I am facing is that whenever I start my application I get the following error:-
    TypeError: Cannot read property 'Zd' of undefined
    ls.sk.sH
    ls.sk.vrQ
    Lightstreamer.PushPage.Mv
    Lightstreamer.PushPage.seekEngine
    initializeDemoEngine
    (anonymous function)

    However this error goes away when I refresh my page. I tried to debug it but could not find out as to why the Lightstreamer object is not created.
    The architecture used is very closely related to the StockListDemo Frames example.

  2. #2
    I have found out that the Vb.LighStreamer object is undefined in the lspushpage.js file.
    Is there any reason for the mentioned problem?
    I have defined a masterRef to a window reference var masterWinRef = self.parent.frames["SLD_LSCONTAINER"];

    Is this a browser specific issue?

  3. #3
    I changed the code to avoid passing the reference of the page where the engine is created as follows:-
    initializeDemoEngine(pushPage, "./commons/lightstreamer/", null,masterWinRef);
    to
    initializeDemoEngineSeek(pushPage);

    Here I am just passing the pushPage reference and seeking the engine by its name.
    Now, I am not getting the error. Is this a frameset or frames issue?
    I am using frames like this:-
    <frameset rows="*,50" border="0" frameborder="0" framespacing="0">
    <frame name="SLD_LSPULLPAGE" src="application.html" border="0" frameborder="0" />
    <frame name="SLD_LSCONTAINER" src="engine_container.html" />
    </frameset>
    And then getting the reference like this:-
    var masterWinRef = self.parent.frames["SLD_LSCONTAINER"];
    So the issue is seekEngine(pushPage,masterWinRef); cannot find the masterWinRef reference.

    Any comments or pointers as to why is this happening?
    Last edited by akshat; July 17th, 2012 at 04:56 PM.

  4. #4
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    Hi,

    do you call setDomain in your pages?
    If so, in your frameset page you should add a <script> element and set the domain with the same value used in your setDomain calls. That should solve the issue




    In any case, I see you're new to the forums. Are you creating a new project or changing an old one?
    If this is a new project I suggest you to use the new Lightstreamer beta version that is going to become our stable release soon.
    Well, or you can start porting the old project to the new Lightstreamer anyway ;-)

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 04:17 PM.