Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Apr 2012
    Location
    Amsterdam
    Posts
    6

    JMS Listiner smartUpdate method stopping every one hour

    Hi,

    I have downloaded Lightstreamer_Moderato_4_0_3_Duomo_20120406 and installed as per guidelines provided

    I have created JAVA JMS Adapter and integrated with ActiveMQ TOPIC listener, it working fine and streaming data but every one hour it stopping and have restart again to work again

    I am using listener.smartUpdate(...) method

    Do we need to change any configuration?

    Regards,
    Viswanadham.

  2. #2
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    973
    The Server exhibits this behavior when it runs in "unregistered" mode.
    You can ascertain that by looking at the first part of the log.

    This happens when the free license configuration is not correct.
    The first part of the Server log should also notify any issues with the license.

  3. #3
    Member
    Join Date
    Apr 2012
    Location
    Amsterdam
    Posts
    6
    thanks for your response
    I think we configured and starting server with out showing any error. see server log below,
    10.May.12 10:23:33,727 < INFO> Checking license file: /usr/local/Lightstreamer_Moderato/conf/licensefile.lic
    10.May.12 10:23:34,281 < INFO> Starting MAC address check
    10.May.12 10:23:34,286 < INFO> Found MAC address XX:YY:SS:AA:ZZ:BB
    10.May.12 10:23:34,286 < INFO> MAC address check successful
    10.May.12 10:23:34,286 < INFO> License correctly bound with the following parameter(s):
    10.May.12 10:23:34,286 < INFO> Client ID : ClientID
    10.May.12 10:23:34,286 < INFO> Mac Address : XX:YY:SS:AA:ZZ:BB
    10.May.12 10:23:34,288 < INFO> Lightstreamer Server starting in Moderato edition

    Note: MAC Address and License Key name hiding here

  4. #4
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    973
    Ok, the Server is not running in unregistered mode.
    We can't figure out any other reason for what you observe, so we need more detailed information.
    What do yo see exactly after one hour? A client disconnection? Just no more data flowing?
    Can it be a limitation on the back-end side, that is, with the ActiveMQ installation?
    Otherwise, can you show us the whole Server log?

  5. #5
    Member
    Join Date
    Apr 2012
    Location
    Amsterdam
    Posts
    6

    Please find log info

    I have attached Lightstreamer, please let me know what went wrong
    Attached Files Attached Files

  6. #6
    Administrator
    Join Date
    Jul 2006
    Location
    Milan
    Posts
    973
    The log shows that a streaming connection gets closed after a few minutes of life and from the Server point of view the connection has been closed by the client.
    However, the client behaves as though the connection had been interrupted by the Server.
    Hence, something wrong seems to have happened in the middle.
    The Server does not exhibit a general malfunctioning and a second session remains alive for all the timespan covered by the log.

    You said that the issue occurs "every one hour", but you only sent a log snippet of 15 minutes.
    Consider that only the full log, covering a few episodes that occur "every one hour", could allow us to make any hypothesis.

    Alternatively, we could concentrate on one single occurrence of the issue.
    Can you confirm that the Client was left unattended while the disconnection occurred?
    As far as we know, the Client and the Server just could not communicate properly, which may be a network level issue, outside Lightstreamer.
    Could you take packet captures on both client and server side and check if you see any packets not reaching the other side?

 

 

Similar Threads

  1. Stopping update rendering when using OverwriteTable
    By igindex in forum Client APIs
    Replies: 1
    Last Post: October 27th, 2009, 04:50 PM
  2. sending multiple snapshot (true) event in smartUpdate()
    By Pradeep Chahal in forum Adapter APIs
    Replies: 6
    Last Post: October 12th, 2009, 12:25 PM
  3. form POST method vs GET method
    By chuan_ckc in forum Client APIs
    Replies: 1
    Last Post: August 20th, 2009, 10:29 AM
  4. stopping, restarting connection
    By rd2008 in forum Client APIs
    Replies: 1
    Last Post: November 26th, 2008, 09:27 AM
  5. Problem with stopping LS server in Linux
    By quanhm in forum General
    Replies: 1
    Last Post: November 16th, 2007, 11:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 01:44 AM.