Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Nov 2011
    Location
    NY
    Posts
    5

    Unhappy dotnet demo Portfolio-Basic not work fine

    With helloWorld dotnet demo, it works fine.
    and then I rewrited the Portfolio-Basic demo myself (to understand how the metadataAdapter works), when i configure the adapters, i followed the steps with DOCS-SDKS/General Concepts.pdf in chapter 1.4
    and i copied the Portfolio_sockets folder under DOCS-SDKs\sdk_adapter_dotnet\examples\Remote_Portfolio_ Adapters\Deployment\Deployment_LS to adapters and i changed the adapters' name in adapters.xml from id STOCKLISTDEMO_REMOTE to OWNSTOCK and adapter name from QUOTE_ADAPTER to OWNSTOCKADAPTER.
    after this, i copied PortfolioDemo_Basic folder and commons folder under pages/demos to pages/OWNStock.
    then i changed pages/OWNStock/PortfolioDemo_Basic/portfolio.js
    line :
    table.setDataAdapter("PORTFOLIO_ADAPTER");
    to
    table.setDataAdapter("OWNSTOCKADAPTER");

    then i start the lightstreamer sever. ( in local with 8080 port).
    after all, i started the demo i rewrited.
    i input the URI redirect the URI to own demo.

    in firefox i saw the errors, it tells me that OWNSTOCKADAPTER not found.(code 17)

    anyone who can help me to fix this error?

    i am chinese, my english is poor. thanks.

    Code:
    <?xml version="1.0"?>
    
    <adapters_conf id="OWNSTOCK">
    
        <metadata_provider>
            <adapter_class>com.lightstreamer.adapters.remote.metadata.NetworkedMetadataProvider</adapter_class>
    
            <param name="request_reply_port">6663</param>
    
        </metadata_provider>
    
        <data_provider name="OWNSTOCKADAPTER">
            <adapter_class>com.lightstreamer.adapters.remote.data.NetworkedDataProvider</adapter_class>
    
            <param name="request_reply_port">6661</param>
    
            <param name="notify_port">6662</param>
    
        </data_provider>
    
    </adapters_conf>

  2. #2
    Member
    Join Date
    Nov 2011
    Location
    NY
    Posts
    5
    Quote Originally Posted by lisicnu View Post
    With helloWorld dotnet demo, it works fine.
    and then I rewrited the Portfolio-Basic demo with myself, when i configure the adapters, i followed the steps with DOCS-SDKS/General Concepts.pdf in chapter 1.4
    and i copied the Portfolio_sockets folder under DOCS-SDKs\sdk_adapter_dotnet\examples\Remote_Portfolio_ Adapters\Deployment\Deployment_LS to adapters and i changed the adapters' name in adapters.xml from id STOCKLISTDEMO_REMOTE to OWNSTOCK and adapter name from QUOTE_ADAPTER to OWNSTOCKADAPTER.
    after this, i copied PortfolioDemo_Basic folder and commons folder under pages/demos to pages/OWNStock.
    then i changed pages/OWNStock/PortfolioDemo_Basic/portfolio.js
    line :
    table.setDataAdapter("PORTFOLIO_ADAPTER");
    to
    table.setDataAdapter("OWNSTOCKADAPTER");

    then i start the lightstreamer sever. ( in local with 8080 port).
    after all, i started the demo i rewrited.
    i input the URI redirect the URI to own demo.

    in firefox i saw the errors, it tells me that OWNSTOCKADAPTER not found.(code 17)

    anyone who can help me to fix this error?

    i am chinese, my english is poor. thanks.

    Code:
    <?xml version="1.0"?>
    
    <adapters_conf id="OWNSTOCK">
    
        <metadata_provider>
            <adapter_class>com.lightstreamer.adapters.remote.metadata.NetworkedMetadataProvider</adapter_class>
    
            <param name="request_reply_port">6663</param>
    
        </metadata_provider>
    
        <data_provider name="OWNSTOCKADAPTER">
            <adapter_class>com.lightstreamer.adapters.remote.data.NetworkedDataProvider</adapter_class>
    
            <param name="request_reply_port">6661</param>
    
            <param name="notify_port">6662</param>
    
        </data_provider>
    
    </adapters_conf>
    i checked my steps with DOCS-SDKS/General Concepts.pdf in chapter 1.4 , but 1.4.6 not clearly, i don't know which file i should modify.


    After all in adapters.xml , the adapter_class node's value i don't know how to set the value.

  3. #3
    Power Member
    Join Date
    Jul 2006
    Location
    Cesano Maderno, Italy
    Posts
    784
    hi,

    all of our demos share a common misc.js file; in that file there is a line like the following one that tells the client wich adapter-set to request to the server:



    as you use OWNSTOCK as adapter-set name you should change such line with the following one:



    that should do the trick

  4. #4
    Member
    Join Date
    Nov 2011
    Location
    NY
    Posts
    5

    Smile

    thanks Mone.

    the problem is fixed.

 

 

Similar Threads

  1. Replies: 1
    Last Post: March 2nd, 2012, 10:46 AM
  2. Some basic questions about LS
    By reutoren in forum Client APIs
    Replies: 1
    Last Post: December 14th, 2011, 11:27 AM
  3. Flex Portfolio Demo Released
    By Alessandro in forum Client APIs
    Replies: 0
    Last Post: October 18th, 2010, 08:39 PM
  4. Replies: 4
    Last Post: January 30th, 2008, 02:47 PM
  5. DotNet Adapter
    By VietXuan in forum Adapter APIs
    Replies: 3
    Last Post: November 5th, 2007, 10:41 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT +1. The time now is 06:03 AM.